You are not logged in.

#1 2012-12-26 21:08:22

shrubuntu
Member
Registered: 2012-12-26
Posts: 16

[SOLVED] Need help setting default boot device in bios

I have two harddrives S0 and S1 my windows partition is on S0 and my archlinux and grub is on S1. The problem is that I can't set the default boot device to S1 only S0. I have to F8 everytime I start up. Is there a way to set S1 as my default boot device. I tried searching this on google but I couldn't find any relevant posts

Thanks,
Shrub

Last edited by shrubuntu (2012-12-27 15:03:26)

Offline

#2 2012-12-26 21:49:53

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Need help setting default boot device in bios

Hi and welcome to the forum.

I have never heard of the term "S0" and "S1" for drives. Perhaps you mean sda and sdb.

Go into the BIOS, choose your equivalent of "Hard disk priority", move the drive that you want to boot first above the rest of the others, and then exit by saving the settings (usually F10). That should do the trick. Alternatively, you could open up the case and move the SATA cables around, but be careful if you use "sdx" name conventions in /etc/fstab.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#3 2012-12-26 21:56:13

shrubuntu
Member
Registered: 2012-12-26
Posts: 16

Re: [SOLVED] Need help setting default boot device in bios

DSpider wrote:

Hi and welcome to the forum.

I have never heard of the term "S0" and "S1" for drives. Perhaps you mean sda and sdb.

Go into the BIOS, choose your equivalent of "Hard disk priority", move the drive that you want to boot first above the rest of the others, and then exit by saving the settings (usually F10). That should do the trick. Alternatively, you could open up the case and move the SATA cables around, but be careful if you use "sdx" name conventions in /etc/fstab.

Thanks for the reply

I made up S0 and S1 for simplicity. sda and sdb makes more sense I suppose.

My BIOS does not recognize sdb in the priority menu, I'll try moving the SATA cables.

Offline

#4 2012-12-27 00:50:42

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: [SOLVED] Need help setting default boot device in bios

This is probably a hardware question that is beyond the scope of an Arch Linux support thread.  But in any case, you should probably have included the make and model of your mobo.  Since every bios is unique, I think it next to impossible to even begin to tell you how to fix this if you don't cough up this info.

Offline

#5 2012-12-27 09:30:25

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Need help setting default boot device in bios

shrubuntu wrote:

My BIOS does not recognize sdb in the priority menu, I'll try moving the SATA cables.

Of course it doesn't recognize them that way... "sda", "sdb", etc., are kernel names (the Linux kernel). The BIOS recognizes them by their brand/serial number. Google "hard disk boot priority", and maybe click the "Images" link to see how the drives are shown.

If the motherboard doesn't remember the boot priority, try the manufacturer's website and see if there's a BIOS update or something.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#6 2012-12-27 15:01:29

shrubuntu
Member
Registered: 2012-12-26
Posts: 16

Re: [SOLVED] Need help setting default boot device in bios

DSpider wrote:
shrubuntu wrote:

My BIOS does not recognize sdb in the priority menu, I'll try moving the SATA cables.

Of course it doesn't recognize them that way... "sda", "sdb",

No, no, I meant that my second harddrive wasn't in the priority menu!

Anyways, I fixed it by switching the SATA cables, it boots properly now. I generated a new fstab as well.

Thanks!

(Please mark as solved)

Offline

#7 2012-12-27 15:02:40

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,917
Website

Re: [SOLVED] Need help setting default boot device in bios

shrubuntu wrote:

(Please mark as solved)

You do this by editting your first post and prepending [SOLVED] to the title.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2012-12-27 15:03:59

shrubuntu
Member
Registered: 2012-12-26
Posts: 16

Re: [SOLVED] Need help setting default boot device in bios

Trilby wrote:
shrubuntu wrote:

(Please mark as solved)

You do this by editting your first post and prepending [SOLVED] to the title.

Ah, thanks
Other forums do not allow editing of titles, so I didn't check

Offline

Board footer

Powered by FluxBB