You are not logged in.

#1 2012-12-27 02:50:13

z3a
Member
Registered: 2012-12-22
Posts: 2

kazam and gtk

Hi,

I'm trying to install Kazam using the PKGBUILD 'kazam-git' or 'kazam' found in the Aur repo. After solving a couple of issues with the dependencies, I manage to install it correctly. But now when I try to run it I've got this error message:

INFO Kazam - Logger intialized.
INFO Kazam - Running on:  
Traceback (most recent call last):
  File "/usr/bin/kazam", line 140, in <module>
    from kazam.app import KazamApp
  File "/usr/lib/python2.7/site-packages/kazam/app.py", line 39, in <module>
    from kazam.frontend.window_area import AreaWindow
  File "/usr/lib/python2.7/site-packages/kazam/frontend/window_area.py", line 29, in <module>
    from gi.repository import Gtk, GObject, Gdk, Wnck, GdkX11
  File "/usr/lib/python2.7/site-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/site-packages/gi/module.py", line 242, in _load
    version)
  File "/usr/lib/python2.7/site-packages/gi/module.py", line 97, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

Any one know a route to solve this, or maybe how to debug the cause of the error?

thanks!

Offline

#2 2013-01-07 08:01:13

jamtat
Member
Registered: 2008-03-13
Posts: 197

Re: kazam and gtk

No solution here. Instead I have a slightly different error to report. When I try to fire up Kazam (kazam-bzr from AUR), I get the following error:

** (kazam:19099): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/kazam", line 146, in <module>
    from kazam.app import KazamApp
  File "/usr/lib/python3.3/site-packages/kazam/app.py", line 39, in <module>
    from kazam.frontend.window_area import AreaWindow
  File "/usr/lib/python3.3/site-packages/kazam/frontend/window_area.py", line 29, in <module>
    from gi.repository import Gtk, GObject, Gdk, Wnck, GdkX11
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/usr/lib/python3.3/site-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python3.3/site-packages/gi/module.py", line 242, in _load
    version)
  File "/usr/lib/python3.3/site-packages/gi/module.py", line 97, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

I have no idea what any of this means. I have a kind of weird, self-built GUI environment that uses the evilwm window manager, so I suspect my problems are related to that. These sorts of applications seem to be built by and for folks running more full-blown, pre-configured GUI environments.

Anyway, I'm anxious to try out this program if anyone can interpret the error message I'm getting and offer pointers for resolving the problems. If that doesn't happen, I'll go back to my command-line utilities (ffmpeg's x11grab these days) or maybe try out ffcast2.

TIA,
James

Last edited by jamtat (2013-01-07 08:02:51)

Offline

#3 2013-01-08 05:49:12

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: kazam and gtk

Sounds like this error. My guess is you need libwnck3.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#4 2013-01-08 08:51:47

jamtat
Member
Registered: 2008-03-13
Posts: 197

Re: kazam and gtk

Thanks for your reply, ConnorBehan. The thread to which you link actually talks about libwebkit rather than libwnck3. I had earlier run across indications that I needed libwebkit and installed webkitgtk2 and webkitgtk3, which is what pacman lists when I search for libwebkit. But that was prior to posting the error output above, so installing it didn't resolve the issue. libwnck3 is, however, a different package and it is not installed on this system. I'll do some further research on that library to see whether it might resolve my problem.

Offline

#5 2013-01-08 20:51:06

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: kazam and gtk

It never hurts to try. The issue is that gobject-introspection loaded gtk3 (as it was designed  to do) but then came across a package whose gtk3 version was not available. It then loaded the gtk2 version to see if "the next best thing" would work, and it did not.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#6 2013-01-09 07:46:16

jamtat
Member
Registered: 2008-03-13
Posts: 197

Re: kazam and gtk

Yeah, you're right, ConnorBehan: installing libwnck did get rid of that error message. But then I got another error message about pulse audio, so I've given up. You see, I'm still lingering in the audio stone age and using alsa without pulse; I'd just begun to get a rudimentary grasp pn alsa when pulse came out, and I'm not eager to start again from scratch learning about pulse and its relation to alsa. So unless I can find a way to make Kazam use alsa instead of pulse, I'll just stick with the command-line screencasting solutions I've cobbled together. Again, thanks for your input.

Offline

Board footer

Powered by FluxBB