You are not logged in.

#1 2012-12-27 13:18:35

Registered: 2012-12-27
Posts: 1

WPA Failed Authentication during installation with wifi-menu

Hi everyone,

I've gone through the Arch Beginners Guide a few times trying to get my first Arch install going and keep hitting the same problem. My wireless connection works fine and with no configuration (apart from entering the passphrase) when using the installation media but when doing the second network setup in the beginners guide using the wifi-menu wlan0 command all I am getting is:

WPA Authentication/Association Failed [FAIL]

ip link reports the interface is up, I have this in my /etc/wpa_supplicant/wpa_supplicant.conf :

ctrl_interface=/var/run/wpa_supplicant GROUP=wheel

        proto=WPA RSN

and my /etc/network.d/wlan0-INTERNETZilog looks like this:

DESCRIPTION='Automatically generated profile by wifi-menu'

I've tried a fair few variations in the wpa_supplicant.conf but when I run this:

wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf 

I get an error telling me that it cannot be parsed. I have cut and paste network block examples from the forums and it still cannot be parsed. I have followed the beginners guide several times to the word, and used the information on WPA Supplicant in the wiki.

There doesn't seemt to be a driver problem, I have an Intel 4965 chipset covered in the open-source Intel drivers and they worked fine for the installation media to get this far. When I run wifi-menu wlan0 my wireless network is found, it asks me for the key and then I get an ncurses-type dialog telling me the connection failed but I can save the configuration anyway.

I don't have any problems in Debian, Slackware or Fedora with connecting wirelessly but I decided it was time to consolidate my distros and just work through one and there is only really Arch or Gentoo that cover my requirements so I really would like to get this working. Gentoo really is a step too far practically though smile

Last edited by zilog6502 (2012-12-27 13:22:51)


#2 2012-12-27 23:11:25

From: United States
Registered: 2012-11-13
Posts: 21

Re: WPA Failed Authentication during installation with wifi-menu

Well, one problem you might run into is, if you try to start one network thing (such as wifi-menu) while another one is running, neither will function properly.

So, from a fresh bootup, in your terminal, try running

$ ps ax | grep wpa

And kill any of the processes.

In mine, I would run something like this:

$ su # become root
# ps ax | grep wpa # list any processes involving wifi 
 1543 ?        Ss     0:00 /usr/sbin//wpa_supplicant -u
 2815 pts/0    S+     0:00 grep wpa
# kill -SIGTERM 1543 # kill them
# ip link set wlan0 down # set the interface down
# ip link set wlan0 up # set the interface up
# wifi-menu # connect to the network
# ping -c 3 # see if you are actually connected

Try that, and see how it works.


Board footer

Powered by FluxBB