You are not logged in.

#1 2013-01-01 05:20:40

u8sand
Member
Registered: 2012-08-15
Posts: 23

Thunar Input/Output error Using OpenNX - Modified

Very strange error.. When connecting (to my own computer) with nx everything seems to work except for thunar. After opening thunar it closes very quickly and *sometimes* returns the error bellow:

Screenshot_010113_00_05_57.jpg

I'd be glad to provide any further information needed. I don't have any out-of-the-ordinary plugins. I used to use thunar through opennx often with no problems. Only recently have I gotten this error and I have been unable to solve it. I'm not sure if I should downgrade nx or thunar. The client or the server? Could it possibly be some setting? After connecting I execute: "exec startxfce4" to start the xfce4 session.

I have already tried creating a new account but it yielded the same result.

Here are some outputted commands I think might help diagnose my problem please tell me if you would like others:

gdb thunar
GNU gdb (GDB) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/thunar...(no debugging symbols found)...done.
(gdb) start
Function "main" not defined.
Make breakpoint pending on future shared library load? (y or [n]) n

Starting program: /usr/bin/thunar 
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3400.3-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffec882700 (LWP 8518)]
[New Thread 0x7fffe5ac4700 (LWP 8520)]
The program 'thunar' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1091 error_code 2 request_code 149 minor_code 8)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[Thread 0x7fffec882700 (LWP 8518) exited]
[Thread 0x7ffff7fb8900 (LWP 8514) exited]
[Inferior 1 (process 8514) exited with code 01]
(gdb) 


pacman -Qs thunar
extra/thunar 1.6.2-1 (xfce4)
    Modern file manager for Xfce
extra/thunar-archive-plugin 0.3.0-2 (xfce4-goodies)
    Create and deflate archives in thunar
extra/thunar-media-tags-plugin 0.2.0-2 (xfce4-goodies)
    Adds special features for media files to the Thunar File Manager
extra/thunar-volman 0.8.0-1 (xfce4)
    Automatic management of removeable devices in Thunar

I hope we can find the solution to this problem. Thank you




-----------------------

Update

After logging in with Slim (not in freenx) everything worked fine. Still before I had no problem with thunar in nx.

I'll need to find another way to fix the permissions issue when logging in with freenx. This probably has something to do with PAM. But thunar must have changed something as well..

I'm now using PCmanFM for the time being which seems to work fine.. its only thunar.

Last edited by u8sand (2013-01-07 16:07:24)

Offline

#2 2013-01-01 06:02:25

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Thunar Input/Output error Using OpenNX - Modified

You should not be using consolekit anymore.  This has been pulled from the repos and logind of systemd should control that funtionality.  Ergo, the use of --with-ck-launch or ck-launch-session will likely only cause breakage.

Offline

#3 2013-01-05 22:53:58

u8sand
Member
Registered: 2012-08-15
Posts: 23

Re: Thunar Input/Output error Using OpenNX - Modified

Yes, though instead of breakage it didn't make any difference. I still have the input/output error, I will probably making a new post soon. Because the problem is focused on thunar WITH opennx, not just thunar.


-----------------

Update

Rather than creating a new post I modified my original post to state the fact that the error is with Freenx.

Last edited by u8sand (2013-01-05 23:15:37)

Offline

Board footer

Powered by FluxBB