You are not logged in.

#1 2013-01-02 15:14:59

shaaraddalvi
Member
Registered: 2013-01-02
Posts: 5

[Solved] Installing on flash-drive, fsck.ntfs not found

Hello Gurus,
I am new to Arch and so I will try to tell you each step I did, so that you can find the problem more easily, I guess..

I wish to switch from Ubuntu to Arch, and I am trying to install Arch Linux (be it without any GUI shell for the time) on my Kingston DataTraveler G3 4GB. I have two of them. I used one as bootable USB stick to install Arch to the another one. I plugged in both of them, booted via the bootable USB stick, used lsblk to find the name of the device I am trying to install Arch on. Then using cfdisk, i made 4 partitions of it:
sdb1 = 200MB (boot)
sdb2 = 2 GB
sdb3 = 1 GB
sdb4 = remaining.
I formatted all the partitions to ext4, using 'mkfs.ext4' on all /dev/sdb1,2,3,4.
After that, I mounted the partition sdb3 on /mnt, made 'boot' and 'home' directories in it, mounted sdb4 on /mnt/home, and sdb1 on /mnt/boot. I used sdb2 as swap, which i was not sure was necessary. I used mkswap /dev/sdb2 and swapon on /dev/sdb2.
Then I changed directory to /mnt, ran 'pacstrap /mnt base base-devel' and let the process complete.
Then I ran
'genfstab -p /mnt >> /mnt/etc/fstab'
'arch-chroot /mnt'
Edited /etc/hostname file, adding 'archlinux'
Made a symbolic link of '/usr/share/zoneinfo/Asia/Calcutta' to '/etc/localtime'
Ran 'locale-gen', the generation completed.
Then ran 'makinitcpio -p linux', the image generation was successful.
After that 'pacman -S syslinux'
Then 'syslinux-install_update -iam'...The MBR was set.
Exited the chroot, unmounted all the drives and then rebooted the system.

I have tried the same method on VirtualBox and after rebooting when I selected 'boot from existing OS', It worked fine.
However in this case, I rebooted using the flash drive on which I was installing Arch, and instead of getting the login of Arch, I got the following message :
Booting the Kernel.
::running early hook [udev]
::running hook [udev]
::Triggering uevents...
::Performing fsck on '/dev/sda3'
(I guess everything is right till here??)
Then,
fsck: fsck.ntfs : not found
fsck: error 2 while executing fsck.ntfs for /dev/sda3
ERROR: fsck failed on '/dev/sda3'
::mounting 'dev/sda3' on real root
mount: unknown filesystem type 'ntfs'
You are now being dropped to an emergency shell.
sh: cant access tty: Job control disabled.

I wish to be able to boot Arch linux from my flash drive, and I am thinking of doing the same on a new 32 GB flash drive or an external HDD I am thinking of buying.
Thanks... smile

Last edited by shaaraddalvi (2013-01-02 16:56:03)

Offline

#2 2013-01-02 15:25:36

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,532
Website

Re: [Solved] Installing on flash-drive, fsck.ntfs not found

You need to modify your syslinux.cfg to point to your actual root.  The installation guesses/assumes that your root partition is sda3, but it your case it is not (sda3 is on the computer's harddrive).

Your's *might* be sdb3 - and probably will be on most boots.  But for a usb you should use UUIDs instead of block names.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-01-02 15:57:41

shaaraddalvi
Member
Registered: 2013-01-02
Posts: 5

Re: [Solved] Installing on flash-drive, fsck.ntfs not found

Thanks a lot! big_smile worked like a charm! I have currently edited the syslinux.cfg with /dev/sdb3... Digging out how to change do it using UUID, Thanks again!

Offline

#4 2013-01-02 16:16:48

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,532
Website

Re: [Solved] Installing on flash-drive, fsck.ntfs not found

Your welcome.  Please prepend "[SOLVED]" to the thread title by clicking 'edit' on your initial post.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB