You are not logged in.

#1 2013-01-05 17:37:42

From: Wisconsin
Registered: 2004-02-25
Posts: 417

Command line display disappears during boot [solved]

I've brought my machine up to date with systemd, and have run into this latest problem.  I boot with syslinux.  My machine has started giving me kernel panics when I boot with the primary configuration, which had


in the append line, I believe to address this very problem.  If I boot with the fallback, which does not have this entry, I get a boot that I can access over ssh, but the command line display disappears after running through a few lines.  Commenting out the acpi language in the primary gives the same result as the fallback.

If I can't boot with it in there, and can't see the screen with it out, what do I do?

I was looking for some information on the boot process to explain what changes during the boot to cause the screen to go from visible to invisible.  When it used to boot, I remember a font change happening part way through the boot, but don't remember what caused it.  Searching for the boot process on the wiki only gives the systemd page, and I didn't find anything there that was helpful in this regard.

I am downloading a live iso and will try booting with that to see if the display issues are present using that approach.

Ok, it had nothing to do with acpi.  I was running the nvidia driver.  My machine has a processor with a gpu, and apparently it decided to hand off to my intel gpu, which has nothing attached to it, instead of sticking with the nvidia.  May have to do with KMS (  So I deleted the nvidia driver per the wiki instructions and added the nouveau driver, enabled the KMS per the instructions, and now I have a command prompt.

Last edited by timm (2013-01-11 20:13:01)


Board footer

Powered by FluxBB