You are not logged in.

#1 2013-01-07 11:46:45

ivoarch
Member
From: the six feet under the ground
Registered: 2011-03-31
Posts: 436

[SOLVED]Strange message after doing something with pacman

I do not know if the problem has something to do with pacman.

Proceed with installation? [Y/n] y
:: Retrieving packages from core...

(2/2) upgrading nss                                                          [###########################################] 100%
ldconfig: File /usr/lib/libwnck-1.so.22.3.31 is empty, not checked.
ldconfig: File /usr/lib/libXRes.so.1 is empty, not checked.
ldconfig: File /usr/lib/libwnck-1.so.22 is empty, not checked.
ldconfig: File /usr/lib/libXRes.so.1.0.0 is empty, not checked.
ldconfig: File /usr/lib/libwnck-1.so is empty, not checked.
ldconfig: File /usr/lib/libXRes.so is empty, not checked.

 
Pacman works well, the only bad is leaving this message of ldconfig.

Do you want to remove these packages? [Y/n] y
(1/1) removing byzanz                                                        [###########################################] 100%
ldconfig: File /usr/lib/libwnck-1.so.22.3.31 is empty, not checked.
ldconfig: File /usr/lib/libXRes.so.1 is empty, not checked.
ldconfig: File /usr/lib/libwnck-1.so.22 is empty, not checked.
ldconfig: File /usr/lib/libXRes.so.1.0.0 is empty, not checked.
ldconfig: File /usr/lib/libwnck-1.so is empty, not checked.
ldconfig: File /usr/lib/libXRes.so is empty, not checked.

How to solve this problem?
Thanks!

Last edited by ivoarch (2013-01-07 12:53:43)


I love GnuEmacs, GnuScreen, ratpoison, and conkeror.
Github )||( Weblog

Offline

#2 2013-01-07 11:59:47

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,329
Website

Re: [SOLVED]Strange message after doing something with pacman

You either ran out of disk space or lost power during the upgrade.  Find that packages that own those files and reinstall them.

Offline

#3 2013-01-07 12:18:46

ivoarch
Member
From: the six feet under the ground
Registered: 2011-03-31
Posts: 436

Re: [SOLVED]Strange message after doing something with pacman

hey Allan

I tried removing the files and reinstall glibc

But I have it bad, now I have problems with the locale

bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = "en_US.UTF-8",
	LC_MONETARY = "en_US.UTF-8",
	LC_NUMERIC = "en_US.UTF-8",
	LC_TELEPHONE = "en_US.UTF-8",
	LC_MESSAGES = "en_US.UTF-8",
	LC_COLLATE = "en_US.UTF-8",
	LC_CTYPE = "en_US.UTF-8",
	LC_TIME = "en_US.UTF-8",
	LC_NAME = "en_US.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C"). 
 
(~)% locale                                                                                                                 :)
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8

Last edited by ivoarch (2013-01-07 12:22:05)


I love GnuEmacs, GnuScreen, ratpoison, and conkeror.
Github )||( Weblog

Offline

#4 2013-01-07 12:52:06

ivoarch
Member
From: the six feet under the ground
Registered: 2011-03-31
Posts: 436

Re: [SOLVED]Strange message after doing something with pacman

Ok I reinstalled these packages
 
sudo pacman -S libwnck libxres

and   

# localedef -v -c -i en_US -f UTF-8 en_US.UTF-8 

now everything works fine smile


I love GnuEmacs, GnuScreen, ratpoison, and conkeror.
Github )||( Weblog

Offline

Board footer

Powered by FluxBB