You are not logged in.

#1 2005-10-02 21:52:53

timm
Member
From: Wisconsin
Registered: 2004-02-25
Posts: 417

Ctrl-Alt-Fn doesn't work from KDE [Solved]

I'm working on learning the ins and outs of linux, and read that I should be able to go from KDE to a virtual terminal by using Ctrl-Alt-Fn for whichever one I want.  I've tried this a couple of times, but it seems to do nothing.

Is there a configuration file that I need to edit to enable this behavior?

Offline

#2 2005-10-02 22:07:22

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Ctrl-Alt-Fn doesn't work from KDE [Solved]

its only availabe F1 - F6. F7 is X (kde running) not letting up on any of the keys. They(F1-F6) don't work?

Offline

#3 2005-10-02 22:07:35

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Ctrl-Alt-Fn doesn't work from KDE [Solved]

Just to be clear: By Fn you mean one of the F1 to F6 keys, right? And not the fn key found on laptops.

The config file is /etc/inittab but you shouldn't need to modify it to switch from KDE to virtual console.  The default one should work.

maybe this will help: http://bbs.archlinux.org/viewtopic.php? … nsole+xorg

Offline

#4 2005-10-03 17:36:15

timm
Member
From: Wisconsin
Registered: 2004-02-25
Posts: 417

Re: Ctrl-Alt-Fn doesn't work from KDE [Solved]

The keypress is indeed, for example, Ctrl-Alt-F3

The thread mentioned by Snowman has the solution.

In xorg.conf, I had to change the keyboard "InputDevice" section by commenting out the "Option 'XkbVariant" line and by adding the value "us" to the "Option XkbLayout" line.  The new section looks as follows:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "CoreKeyboard"
        Option "XkbRules" "xfree86"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us"
#       Option "XkbVariant" "nodeadkeys"

--------------
I haven't played with combinations of the above.
For reference (for those who follow), xfree86.org says:

# XkbLayout - layout(s) you intend to use
# XkbVariant - variant(s) of layout you intend to use

Thanks for the help!

Offline

Board footer

Powered by FluxBB