You are not logged in.

#1 2013-01-08 18:04:36

From: Germany near Bremen
Registered: 2009-08-30
Posts: 30

ATI HD 6850 / "Pink Screen" / nomodeset


since upgrading one of my archboxes in mid-december (AFAIR) including Kernel and ATI-xorg-drivers, i have a big Problem.

My System:
AMD Phenom II X4 920
AMD Radeon HD 6850
21" Samsung CRT "Sync Master 1100p plus" using an KVM-Switch*
NVIDIA Chipset
Archlinux 64bit with systemd / grub2 installed around summer (afair)

Windows 8 on a second HDD works fine, even with games Like Diablo3 or BF3

My other archlinux box, (32bit, onboard ATI card) sharing the same Monitor with KVM works fine with the same resolution.

Not Working
If i'm not using "nomodeset" as a kernel-parameter, i only get when booting to X a kind of not easy to describe kind of "pink screen with small lines", but no usable picture. Switching to the Virtuel Console 1 with Ctrl+Alt+F1 does "something". The Screen goes nearly complete black with some green lines and some green squares ... in the first "line" on the screen can perceive some grey lines, a bit looking like letters.
Before the update, everything worked fine with KMS

A bit working
To get a usable Screen i tried, after a bit of research, the kernel line "no mode set" which helped immediately - the virtual console is OK, and X ist starting with the right resolution (1600x1200) but unfortunately with the wrong refresh rate. As i'm using an 21" crt this should be around 100hz, but i suspect it is more or less around 60hz, staring at it longer times isn't very comfortable.

I'm using no xorg.conf and in /etx/X11/xorg.conf.d/ are only two *.conf for input devices.
With "nomodeset" enabled i get this log:

Idea one:
I tried setting the right refresh rate like stated in the wiki … ng_started But with such an conf crashes immediately.
/edit i get xorg-errors like:
Screen deleted because of no matching config section
Device(s) detected, but none match the config

Idea two:
Reinstallation xorg and the ati drivers: Nothing changes

Idea three;
Using KMS "earlystart": Nothing changes

Idea four:
Using xrandr to set the right frequency:
xrandr --newmode "1600x100_60.00"   12.75  1600 1648 1800 2000  100 103 113 116 -hsync +vsync
Result: Nothing changes

Has anyone an idea? I know this is not very specific, i could try to make a photo without "nomodeset" if it helps, or paste some more xorg.logs or try to give you every piece of information you want.

Would it help installing the catalyst driver?

Thanks for your Help!

Last edited by Zeddi (2013-01-08 18:07:22)

I'm not very used to write English since i've left School, so please be patient!


Board footer

Powered by FluxBB