You are not logged in.

#1 2013-01-08 22:47:22

From: /dev/null
Registered: 2012-04-30
Posts: 7

Cannot build lib32-wxgtk

G'day, Arch veterans.

whenever I try to compile lib32-wxgtk, I get this:

checking for GTK+ - version >= 2.0.0... 
*** 'pkg-config --modversion gtk+-2.0' returned 2.24.13, but GTK+ (2.24.14)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

I have "base-devel" installed, lib32-gtk2 and other stuff like that. I tried to search the forums and seen it being solved through updating, but it didn't work in my case.

I just don't know what to do. Any ideas about this? How can I solve the problem?

Thank you in advance.


#2 2013-01-25 16:08:46

Registered: 2013-01-25
Posts: 2

Re: Cannot build lib32-wxgtk

I have the same problem.
You still have not compiled this package?


#3 2013-01-25 16:43:37

Registered: 2013-01-25
Posts: 2

Re: Cannot build lib32-wxgtk

Oh, I found a solution. Just pacman -Syu your system.


#4 2013-01-25 16:44:03

From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,695

Re: Cannot build lib32-wxgtk

builds ok with makepkg here.

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them


Board footer

Powered by FluxBB