You are not logged in.

#1 2005-10-04 11:08:51

onami
Member
From: Romania
Registered: 2004-05-05
Posts: 197

Xorg tcp socket

hello,

after yesterday's update, after connecting through ssh on another machine, and after xhost +,
exporting the DISPLAY from the ssh connection to onami:0 (my host), it says

igrigore@hydra:~$ xedit
Error: Can't open display: onami:0

And netstat on my machine (onami):

sudo netstat -tpan

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      2853/sshd           
tcp        0      0 10.3.2.24:32780         10.2.4.65:143           ESTABLISHED 5506/thunderbird-bi
tcp        0      0 10.3.2.24:59591         10.3.2.10:22            ESTABLISHED 5456/ssh           
tcp        0      0 10.3.2.24:59664         216.155.193.153:5050    ESTABLISHED 5443/gaim           
tcp        0      0 10.3.2.24:22            10.3.2.23:40248         ESTABLISHED 4057/sshd: cristi [


the 6000 port on my machine is not opened, so X server does not receive remote connections.

i found this on google few month ago when i was struggleing to help a friend pass this problem, but here that file is missing:

"Set DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" in the /etc/sysconfig/displaymanager file"

does anyone know where can i enable the tcp socket connection to my X server, instead of a unix socket one ?


Forever newbie !!!

Offline

#2 2005-10-04 12:30:49

sh__
Member
Registered: 2005-07-19
Posts: 271

Re: Xorg tcp socket

I'm not sure if I'm reading your question right, but usually you can forward X11 connections over ssh without opening the port 6000 on the server. There should be no need to play with the xhost command either.

The machine running sshd (let's call it remotehost) should be configured to allow X11 forwarding over ssh. This is accomplished if /etc/ssh/sshd_config on remotehost contains the line

X11Forwarding yes

Also, /etc/hosts.allow should be configured to allow incoming ssh connections:

sshd: ALL

or you can restrict it to a certain ip range (see wiki).

Now you should be able to start xedit on remotehost by using the following command on another machine (call it localmachine):

ssh -fX remotehost xedit

Ssh should take care of setting the right DISPLAY variable for localmachine.

Offline

#3 2005-10-05 06:23:08

onami
Member
From: Romania
Registered: 2004-05-05
Posts: 197

Re: Xorg tcp socket

X11Forwarding yes

is set on the host that receiveis the ssh connection.
that is not the problem, the problem is that my X11 server does not open the 6000 port, for remote connections, it opens a unix socket instead.

ssh -fX igrigore@hydra nedit
igrigore@hydra's password:
[ionut@onami ~]$ NEdit: Can't open display

if the X server opens a tcp socket, and i give

xhost +

any host on the network that uses my display and opens a X application, will open that application on my X, my computer.


But I can't open a darn X app on the remote host.


Forever newbie !!!

Offline

#4 2005-10-05 21:29:56

onami
Member
From: Romania
Registered: 2004-05-05
Posts: 197

Re: Xorg tcp socket

I found the problem :
X connections were blocked from gdm, i just unchecked that checkbox  smile


Forever newbie !!!

Offline

Board footer

Powered by FluxBB