You are not logged in.

#1 2013-01-16 23:45:57

d4ft
Member
Registered: 2010-12-20
Posts: 9

Still stuck on 3.3.1

Ok guys, so here's the problem. Ever since I upgrade to any kernel version beyond 3.3.1 I get very terrible responsiveness from my computer. I can't figure out what has caused the system to be so slow. I have tried targeting the causes via iotop, top and fine tune some stuffs for my ext4 partitions but there's nothing out of the ordinary.

Here's a list of some of the problems:

- The 'highlights' on awesome wm's app launcher take a few milliseconds to catch up with the cursor when it hovers from app to app
- Web pages like facebook take AWFULLY long to load.
- Opening applications even like rxvt take noticeably longer to load
- Pacman takes a long time to load packages

All these problems always occur whenever I upgrade the kernel and disappear following the downgrade back to 3.3 regardless of package upgrades. I'm at my wits end. Can somebody please point me in the right direction on how to proceed from here?

Offline

#2 2013-01-17 00:23:14

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,273

Re: Still stuck on 3.3.1

Some more information about your system, hardware, DE, etc. would really help.


To know or not to know ...
... the questions remain forever.

Offline

#3 2013-01-17 21:35:12

mich41
Member
Registered: 2012-06-22
Posts: 643

Re: Still stuck on 3.3.1

Anything suspicious in dmesg?

Swapping?

Excessive interrupts? (watch -n1 cat /proc/interrupts)

Online

#4 2013-01-17 22:11:40

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,818
Website

Re: Still stuck on 3.3.1

Odd... have you tried the linux-ck package?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB