You are not logged in.

#1 2013-01-17 01:50:41

tophzilzaal
Member
Registered: 2013-01-17
Posts: 4

Installing kazam

The version of kazam listed in the AUR is outdated, I'm trying to install the newest version, I tried making a pkgbuild file (I've only been using arch a couple days so it was my first), this is what I ended up with:

http://pastebin.com/uvVZAQvZ

I ran makepkg and pacman, I got a kazam icon, but it wasn't working, so I uninstalled it, and tried to install it directly via the setup.py file, still no luck. That makes me think maybe I'm missing a dependency, but I have no idea what.

Offline

#2 2013-01-17 02:35:36

Bandit Bowman
Member
Registered: 2010-08-25
Posts: 18

Re: Installing kazam

How do you mean not working?
Run it at a terminal, see if you get any useful output.

Offline

#3 2013-01-17 02:58:24

tophzilzaal
Member
Registered: 2013-01-17
Posts: 4

Re: Installing kazam

Not working as in not launching, it's supposed to have a GUI, it's a screen recording program.

Offline

#4 2013-01-17 10:20:28

cumali
Member
Registered: 2012-03-19
Posts: 7

Offline

#5 2013-01-17 12:34:07

satanselbow
Member
Registered: 2011-06-15
Posts: 535

Re: Installing kazam

The code is called "unstable" for a reason... for the record the "stable" version on launchpad is pretty buggy too sad

If you can't debug python - look elsewhere for a solution as suggested above sad

Offline

#6 2013-01-17 23:11:01

tophzilzaal
Member
Registered: 2013-01-17
Posts: 4

Re: Installing kazam

I hadn't heard of the vokoscreen, I will give it a go today. I the eman time, I've figured out which dependency was missing and not allowing the program to run (dbus-python), now I have an error though:

ERROR Kazam - Could not find any typelib for Keybinder
INFO Indicator - Unable to import Keybinder, hotkeys not available.

(kazam:28109): Gtk-WARNING **: Can't set a parent on widget which has a parent
(kazam:28109): Gtk-WARNING **: Can't set a parent on widget which has a parent

No idea what the last error means, and I couldn't find a python 3.x bindings for keybinder, do they exist?

Offline

#7 2013-01-17 23:29:14

tophzilzaal
Member
Registered: 2013-01-17
Posts: 4

Re: Installing kazam

Actually it's way more complex, there's problems with the python code,  I'd have to fix it to get to do anything, thanks for the help guys!

Update: trouble with voko is the lack of hotkeys, but since they weren't there in kazam either, I guess that's ok

Last edited by tophzilzaal (2013-01-17 23:31:33)

Offline

Board footer

Powered by FluxBB