You are not logged in.

#1 2013-01-17 14:01:31

Registered: 2012-08-21
Posts: 9

Unexplained data corruption on USB 3.0 pen drive


I've been trying to setup a small home server and my plan was to run it from a USB 3.0 pen drive, so that I can spin-down the (software raid 1) data disks when idle.
So, initially I got a cheap USB 3.0 pen drive and started installing a default Arch. This worked without too many problems, though for some strange reason I could not select the pen drive as the boot device, while it was plugged into a USB 3.0 port. However on a USB 2.0 port it worked fine. I contacted the motherboard vendor and they kept claiming that booting from USB 3.0 should not be a problem, so I ended up buying a second pen drive, one which they claimed was bootable for them. That turned out to be correct, after rsync-ing the contents of the first pen drive to the new one, I could also boot from it.

So far, so good.

But then after a few days of not doing much on the machine, all of a sudden I noticed that a few files had been corrupted. Most notably my .bashrc. It seems like some characters had just been replaced by random other characters. I believe the overall size and also the last modified date did not change. (Although I'm not 100% sure here.)

So figured there could be some hardware issue here. But so far I have not been able to figure out what could cause the issue. I checked:

- The journal/dmesg does not contain any strange error reports.
- Running fsck (force) does not detect any problems.
- Running memtest86 for over 12 hours does not find any problems.
- Running a destructive badblocks test several times on the new pen drive does not produce any errors.

What seems strange to me is that I did not have any problems with the first pen drive, so that would suggest something is wrong with the new one. But then I don't get why I can't seem to find anything wrong with it using badblocks. Basically the machine just sits idle for a day or so, and then when I log in again I find corruption in files of which I am sure that there was nothing that should have been writing to them.

If anyone would have any tips on how to further diagnose these problems I would highly appreciate it.


Ps. Not sure if it's relevant but the motherboard is a MSI B75MA-P45, and the USB stick is a Corsair Flash Voyager GT 16 GB.


Board footer

Powered by FluxBB