You are not logged in.

#1 2013-01-18 09:27:34

capthilts
Member
Registered: 2012-01-20
Posts: 18

Problem & solution: ata1: exception Emask 0x10 & no optical drive

First of, please forgive if a thread such as this one already exits - I didn't find it.

Recently I have encountered a major issue with my newly acquired computer, and couldn't find a solution anywhere in this forum. In the meantime I managed to fix the problems and would like to share the solution - in case somebody else might encounter the same (or similar) problem.

Ok, let's start with the specs:

Intel i7 3770s
16GB RAM
64GB SSD
1TB HDD
Optical Drive
OS: no OS pre-installed

Setup:

I have set up an ArchLinux 64-Bit system which - after a couple of minor adaptations to 1-2 config files - ran out-of-the-box, 100% working. Desktop of choice is KDE, configured to the bone.

What led to the troubles:

After everything was up and running I started to experiment with some config files. One of the little tweaks I tried was to enable "sna" in the 20-intel.conf. Next, I wanted to setup the second monitor, in this case a TV, connected via HDMI. Then, I started to test whether to clone the display or go with an extended display. Cloning seemed the way to go. When watching a film, I could simply disable the computer screen (room is not that big and moving the computer seems impractical). So, before enjoying a movie I disabled the computer monitor. Afterwards I wanted to enable it again. And this is where the troubles began...The system froze and after a while I decided to forcefully shutdown the computer:

Issues:

While before the incident, the computer was booting up in sth like 10sec with no error messages no matter what kernel I used (well, not true, for whatever reason linux-lts doesn't work on my computer - instead of starting KDM it stays black; however, that's another story), now the following things started to occur:

- it took up to 30sec for the BIOS to recognize that there is a disk (SSD in this case)
- the optical drive didn't respond anymore: not even at the BIOS level!
- booting the system took a lot longer
    - when booting I got an ata1 error message (unfortunately I wiped the drive so I don't have the log files anymore), which looked like this:
          - ata1: exception Emask 0x10 SAct 0x0 SErr 0x404 action 0xe froten t4 (down to t0)
            ata1: irq_stat 0x00000040 connection status changed
- optical drive made quite some noise, yet impossible to open it

Trying to solve the issue:
- booting into a live system:
  - since I couldn't open the optical drive anymore I had to create a liveUSB instead
  - tried to repair the bad sectors it spit out: e2fsck -cfpv /dev/"name_drive" -->didn't not work
- wiped the entire SSD, wanted to reinstall the system, but:
  - error persisted even when booting into the live system (ata1 error messages and optical drive not working)

Solving the issue:
- stumbled upon an article that suggested the SSD might not be connected properly:
  - since the system was working without any issues for a month now I didn't even consider the option: anyway, I still decided to open up the machine and check: everything was connected properly
- decided to disconnect the SSD and remove it (the removing part was probably more an act of despair because disconnecting would've sufficed)
- connected the SSD again, closed the machine and gave it another go:

Result:
- Optical drive working again
- Bootspeed back to normal
- No error messages
- Problem solved!

I hope this will be of any use should someone run into a similar issue. Also, hopefully trying this before wiping the disk (I didn't back up the system...tho, it's fun setting up arch smile)

Cheers
Capt.

Last edited by capthilts (2013-01-18 14:42:19)

Offline

#2 2013-01-18 14:37:50

nixpunk
Member
Registered: 2009-11-23
Posts: 268

Re: Problem & solution: ata1: exception Emask 0x10 & no optical drive

A thread title indicative of the original problem would be more useful.  Regardless, thanks for sharing.

Offline

#3 2013-01-18 14:45:07

capthilts
Member
Registered: 2012-01-20
Posts: 18

Re: Problem & solution: ata1: exception Emask 0x10 & no optical drive

edited the title, thx.

Initially, the idea was to create a general thread for problems & solutions (I know the wiki awesome, yet sometimes when browsing the forums it might be cool to have a centralized thread where the poster doesn't just ask for help, but in fact already has a solution for others too).

Cheers

Offline

#4 2013-01-18 14:51:13

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,271

Re: Problem & solution: ata1: exception Emask 0x10 & no optical drive

capthilts this does not really fit in a discussion forum.
You should rather consider getting a blog for this and/or use the wiki.


To know or not to know ...
... the questions remain forever.

Online

#5 2013-01-18 15:02:33

capthilts
Member
Registered: 2012-01-20
Posts: 18

Re: Problem & solution: ata1: exception Emask 0x10 & no optical drive

duly noted

Offline

Board footer

Powered by FluxBB