You are not logged in.

#1 2013-01-19 14:08:13

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

[SOLVED][ish] amixer sset Master toggle mutes all channels

As mentioned in the title, amixer appears to mute all audio channels but doesn't unmute them when run again. As a result, the media key I'd like to serve as mute/unmute only works to mute, and I need to go into alsamixer manually to unmute them.

If I understood correctly, amixer sset Master toggle would only affect the master channel, when that obviously isn't what is happening. Is anyone experiencing this issue, does anyone know how I could change this behavior?

Any and all help is appreciated, as always.

[Edit]: I've switched to aur/ponymix as it appears to function properly.[/Edit]

All the best,

-HG

Last edited by HalosGhost (2013-01-19 14:24:05)


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Online

#2 2013-01-22 09:58:57

ball
Member
From: Germany
Registered: 2011-12-23
Posts: 164

Re: [SOLVED][ish] amixer sset Master toggle mutes all channels

I experience exactly the same issue as you. Until now I didn't find any solution to this... :-(

Offline

#3 2013-01-22 21:38:26

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: [SOLVED][ish] amixer sset Master toggle mutes all channels

ball wrote:

I experience exactly the same issue as you. Until now I didn't find any solution to this... :-(

I've been led to believe it is an upstream bug with alsa, and that amixer itself is largely broken in this respect. For that reason, I would strongly suggest (as was suggested to me) to switch to aur/ponymix, as listed in the OP.

All the best,

-HG


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Online

Board footer

Powered by FluxBB