You are not logged in.

#1 2013-01-20 09:36:38

Helmsen
Member
Registered: 2013-01-19
Posts: 15

No eth0 device

Hi guys,

I've installe archlinux. All works, except the wired network connection (never tried wireless).
When i was using the live system, it worked. But since I've installed arch on disk it doesn't work anymore.

"ip addr show" shows only lo.No eth0 or eth1.

I tried dhcpcd commands because i read in other threads to try this, but nothing works.
So what could be wrong? Do i have to reinstall my system?

Helmsen

Offline

#2 2013-01-20 09:44:46

kaszak696
Member
Registered: 2009-05-26
Posts: 543

Re: No eth0 device

During the 197 systemd update the naming scheme of network interfaces changed, and is default for new installations. Check this.


'What can be asserted without evidence can also be dismissed without evidence.' - Christopher Hitchens
'There's no such thing as addiction, there's only things that you enjoy doing more than life.' - Doug Stanhope
GitHub Junkyard

Offline

#3 2013-01-20 13:28:32

Helmsen
Member
Registered: 2013-01-19
Posts: 15

Re: No eth0 device

I couldn't solve the problem with this article.
But now i know, that my devices are named as enp3s0 and wlp5s0.
But how can i tell the system, that enp3s0 is my eth0 device?

Offline

#4 2013-01-20 13:48:07

Sanne
Member
Registered: 2012-03-13
Posts: 87

Re: No eth0 device

This post gives a bit more info. In this thread the change is discussed.

I can't help with specifics though, because existing installs have to opt in for the change, which I haven't done yet. But maybe those links help you further.

Last edited by Sanne (2013-01-20 13:49:56)


If our currency were not money but appreciation and acknowledgement for what we do for others, for the community, for the benefit of all, we would have paradise on earth.

Offline

#5 2013-01-20 14:03:35

defmacro
Member
Registered: 2013-01-20
Posts: 2

Re: No eth0 device

You should make sure your systemd is running directly.
Check it by
# systemctl status
Then check its outputs if there is D-bus fail.

Offline

#6 2013-01-20 14:07:26

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,135
Website

Re: No eth0 device

Follow the beginners guide to manually connect to the internet:
https://wiki.archlinux.org/index.php/Be … uide#Wired
# ip link
# ip link set enp2s0f0 up
#ip addr add 192.168.1.2/24 dev enp2s0f0
# ip route add default via 192.168.1.1
# nano /etc/resolv.conf

This is the best method to begin with, because every step will give you output in case of errors.

Offline

#7 2013-01-20 14:09:44

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,043

Re: No eth0 device

Helmsen wrote:

I couldn't solve the problem with this article.
But now i know, that my devices are named as enp3s0 and wlp5s0.
But how can i tell the system, that enp3s0 is my eth0 device?

dhcpcd enp3s0

Post the whole output if it fails.


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#8 2013-01-20 21:49:18

Helmsen
Member
Registered: 2013-01-19
Posts: 15

Re: No eth0 device

# ip link
# ip link set enp2s0f0 up
#ip addr add 192.168.1.2/24 dev enp2s0f0
# ip route add default via 192.168.1.1
# nano /etc/resolv.conf

Did all this steps except editing /etc/resolv.conf. I live in a dorm and have to use their connection to the internet. Their domain is registered so i think it should be allright.
"ip link" lists 1.lo 2.enp3s0 3.wlp5s0
When i use "ip link set enp3s0 up", enp3s0 stays at position 2.


Output dhcpcd enp3s0:
dhcpcd[1772]: version 5.6.4 starting
dhcpcd[1772]: enp3s0: waiting for carrier
dhcpcd[1772]: enp3s0: carrier acquired
dhcpcd[1772]: enp3s0: sending IPv6 Router Silicitation
dhcpcd[1772]: enp3s0: sendmsg: Cannot assign requested address
dhcpcd[1772]: enp3s0: rebinding lease of 10.84.176.2
dhcpcd[1772]: enp3s0: Router Advertisement from fe80::3433:8ed8:9cf2:e0e0
dhcpcd[1772]: enp3s0: did not fork due to an absent RDNSS option in the RA
dhcpcd[1772]: enp3s0: no support for DHCPv6 management
dhcpcd[1772]: enp3s0: Router Advertisement from fe80::5970:78a:eb43:cd7d
dhcpcd[1772]: enp3s0: did not fork due to an absent RDNSS option in the RA
dhcpcd[1772]: enp3s0: boradcasting for a lease
dhcpcd[1772]: enp3s0: offered 10.84.176.2 from 10.84.0.2
dhcpcd[1772]: enp3s0: acknowledged 10.84.176.2 from 10.84.0.2
dhcpcd[1772]: enp3s0: checking for 10.84.176.2
dhcpcd[1772]: enp3s0: leased 10.84.176.2 for 10800 seconds
dhcpcd[1772]: forked to background, child pid 2367

Offline

#9 2013-01-20 22:16:41

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: No eth0 device

So does it work now? You've got an ip address, the interface is up...

Please use [code ][/code ] tags (w/o the spaces).


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#10 2013-01-20 23:00:25

waldauf
Member
Registered: 2012-07-15
Posts: 124

Re: No eth0 device

Hi,

I may be have the same problem. I have set eht0 to UP state but cannot see it in ''addr'' state. If is this another problem I'll create new thread.

This is output of link:

# ip link show
1:  lo:...
~
2:  etho: <BRADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
       link/ether <MAC.ADDR> brd ff:....:ff

Then I start dhcp client:

# dhcpcd eth0
dhcpcd[5953]: version 5.6.4 starting
dhcpcd[5953]: eth0: rebinding lease of 192.168.1.117
dhcpcd[5953]: eth0: acknowleded 192.168.1.117 from 192.168.1.1 'ÿ'
dhcpcd[5953]: eth0: checking for 192.168.1.117
dhcpcd[5953]: eth0: leased 182.168.1.117 for 7200 seconds
dhcpcd[5953]: eth0: etho0: MTU set to 576
dhcpcd[5953]: forked to background, child pid 5983

BUT in addr I cannot see the result IP address:

# ip addr show
1. lo: <LOOPBACK,UP,LOWER_UP> ....
     inet 127.0.0.1/8 scope host lo
#

I tried to set IP address manualy but with the same result. I cannot ping any server and continue with installation of ARCH.

Offline

#11 2013-01-20 23:00:57

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,043

Re: No eth0 device

So it works fine. Just enable the dhcpcd service then (optionally explicitly for that interface)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#12 2013-01-20 23:08:34

waldauf
Member
Registered: 2012-07-15
Posts: 124

Re: No eth0 device

Mr.Elendig wrote:

So it works fine. Just enable the dhcpcd service then (optionally explicitly for that interface)

I did these steps - https://wiki.archlinux.org/index.php/Ne … ng_systemd - but with the same result.

This is output of status:

# systemctl status network
network.service - Network Connectivity
          Loaded: loaded (/etc/systemd/system/network.service; enabled)
          Active: active (exited) since Mon 2013-01-21 00:10:03 UTC; 2min 10s ago
         Process: 412 ExecStart=/sbin/dhcpcd eth0 (code=exited, status=0/SUCCESS)
         Process: 404 ExecStart=/sbin/ip link set dev eth0 up (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/network.service
                  `-449 /sbin/dhcpcd eth0

Jan 21 00:11:58 pizduch dhcpcd[449]: [53B blob data]
Jan 21 00:11:58 pizduch dhcpcd[449]: eth0: checking for 192.168.1.117
Jan 21 00:12:04 pizduch dhcpcd[449]: eth0: leased 192.168.1.117 for 7200 seconds
Jan 21 00:12:04 pizduch dhcpcd[449]: eth0: carrier lost
Jan 21 00:12:05 pizduch dhcpcd[449]: eth0: carrier acquired
Jan 21 00:12:06 pizduch dhcpcd[449]: eth0: rebinding lease of 192.168.1.117
Jan 21 00:12:06 pizduch dhcpcd[449]: [53B blob data]
Jan 21 00:12:06 pizduch dhcpcd[449]: eth0: checking for 192.168.1.117
Jan 21 00:12:11 pizduch dhcpcd[449]: eth0: leased 192.168.1.117 for 7200 seconds
Jan 21 00:12:11 pizduch dhcpcd[449]: eth0: carrier lost

Last edited by waldauf (2013-01-20 23:13:51)

Offline

#13 2013-01-21 00:34:21

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: No eth0 device

Just use dhcpcd.service

Offline

#14 2013-01-21 10:18:37

Helmsen
Member
Registered: 2013-01-19
Posts: 15

Re: No eth0 device

using

dhcpcd enp3s0

works!

I tried that command after installing the system, but with dhcpcd eth0.
So I think it didn't work, because my device is named enp3s0
I have to retype dhcpcd enp3s0 after rebooting, but I think there is a solution in the beginners guide.

Thanks for your help guys!

Offline

#15 2013-01-21 11:43:19

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,043

Re: No eth0 device

Helmsen wrote:

using

dhcpcd enp3s0

works!

I tried that command after installing the system, but with dhcpcd eth0.
So I think it didn't work, because my device is named enp3s0
I have to retype dhcpcd enp3s0 after rebooting, but I think there is a solution in the beginners guide.

Thanks for your help guys!

anonymous_user wrote:

Just use dhcpcd.service

or symlink dhcpcd@enp3s0.service yourself.

Relevant bug reports:
https://bugs.archlinux.org/task/31093
https://bugs.archlinux.org/task/33415

Last edited by Mr.Elendig (2013-01-21 11:44:08)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#16 2013-01-21 18:44:47

hawaiicharles
Member
Registered: 2012-12-21
Posts: 71

Re: No eth0 device

I realize this question might not be immediately answerable since it's an upstream issue, but I'm wondering:  Is this new naming convention a permanent change, or is it some sort of temporary glitch particular to systemd-197?

Offline

#17 2013-01-21 18:46:41

kaszak696
Member
Registered: 2009-05-26
Posts: 543

Re: No eth0 device

Permanent, unless a better solution is found.


'What can be asserted without evidence can also be dismissed without evidence.' - Christopher Hitchens
'There's no such thing as addiction, there's only things that you enjoy doing more than life.' - Doug Stanhope
GitHub Junkyard

Offline

#18 2013-01-21 18:55:27

chris_l
Member
Registered: 2010-12-01
Posts: 390

Re: No eth0 device

hawaiicharles wrote:

I realize this question might not be immediately answerable since it's an upstream issue, but I'm wondering:  Is this new naming convention a permanent change, or is it some sort of temporary glitch particular to systemd-197?

Is not a glitch; read official info here: http://www.freedesktop.org/wiki/Softwar … rfaceNames


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

Board footer

Powered by FluxBB