You are not logged in.

#1 2013-01-20 10:29:41

From: Pisa,Italy
Registered: 2009-07-18
Posts: 148

joystick range problem

I have two non-original playstation 1 controllers connected with usb adapters. They are correctly recognized as generic USB joypads, however the range of the sticks seems to be limited - what I mean is that they start sending non-zero values when they're allready quite far away from the center and reach maximum value way before the stick is actually all the way through.

I tested this with jstest, xinput and qjoypad, both with and without xf86-input-joystick installed. I even tried recallibrating them with "jscal -c" but it didn't change. (BTW jstest and jscal are the debugging programs mentioned in the kernel docs, from inpututils-cvs in AUR).

I would say it should be a defective joystick, but the two are actually a different brand.... Plus the range is very limited (and identical on both BTW), making the joystick useless, and they are quite new, so it seems unlikely to me it be a hardware issue - or maybe something with the psx-usb adapter? Software wise what else could I try?

Last edited by Nareto (2013-01-20 10:31:09)


#2 2013-01-29 00:05:57

Registered: 2013-01-24
Posts: 1

Re: joystick range problem

I've had a Teensy microcontroller setup as a controller with two sticks and four buttons. The controller would only work on my desktop after calibration through jscal. Regardless of what I tried on my laptop, however, one of the joysticks seemed to be off always, almost as if it was a hardware issue. (Only one axis worked, the other would break in the top-right quadrant.) The only difference between my desktop and my laptop was the kernel I had running.

My desktop was using 3.2.1, laptop with 3.6. After switching from 3.6 to 3.2.1, the controller worked on both machines. You could give swapping the kernel out a try.


Board footer

Powered by FluxBB