You are not logged in.

#1 2013-01-24 09:05:22

rchiang
Member
Registered: 2012-07-05
Posts: 13

Couldn't add "network interface" in virt-manager

I'm using arch 64bits linux.

Reproduce steps
1. start libvirtd
2. launch virt-manager
3. From menu, "Edit" -> "connection details" -> "network interface"

There is no interface showing in the left side.
And if press "+" button to add an interface, I get following error:

Error creating interface: 'Could not define interface: internal error could not get interface XML description: unspecified error - aug_save failed'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 96, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createinterface.py", line 1135, in do_install
    self.interface.install(meter, create=activate)
  File "/usr/lib/python2.7/site-packages/virtinst/Interface.py", line 242, in install
    raise RuntimeError(_("Could not define interface: %s" % str(e)))
RuntimeError: Could not define interface: internal error could not get interface XML description: unspecified error - aug_save failed

I'm using netcfg to configure my network.

$ ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state UP qlen 1000
    link/ether 90:b1:1c:7f:8b:31 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::92b1:1cff:fe7f:8b31/64 scope link 
       valid_lft forever preferred_lft forever
3: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 90:b1:1c:7f:8b:31 brd ff:ff:ff:ff:ff:ff
    inet 10.67.9.39/24 brd 10.67.9.255 scope global br0
    inet6 2001:470:f3ef:854:92b1:1cff:fe7f:8b31/64 scope global dynamic 
       valid_lft 2591864sec preferred_lft 604664sec
    inet6 fe80::92b1:1cff:fe7f:8b31/64 scope link 
       valid_lft forever preferred_lft forever
6: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN 
    link/ether c6:fa:0c:5e:0b:4c brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
$ cat /etc/network.d/br0 
INTERFACE="br0"
CONNECTION="bridge"
DESCRIPTION="Bridge"
IP='dhcp'

# Add your network adapter(s) here, separated by spaces.
BRIDGE_INTERFACES="eth0"
$ cat /etc/conf.d/netcfg
# Enable these netcfg profiles at boot time.
#   - prefix an entry with a '@' to background its startup
#   - set to 'last' to restore the profiles running at the last shutdown
#   - set to 'menu' to present a menu (requires the dialog package)
# Network profiles are found in /etc/network.d
NETWORKS=(br0)

# Specify the name of your wired interface for net-auto-wired
WIRED_INTERFACE="eth0"

# Specify the name of your wireless interface for net-auto-wireless
WIRELESS_INTERFACE="wlan0"

# Array of profiles that may be started by net-auto-wireless.
# When not specified, all wireless profiles are considered.
#AUTO_PROFILES=("profile1" "profile2")

Other network functions work well.

Offline

#2 2016-02-04 12:03:17

darkbasic
Member
Registered: 2015-06-22
Posts: 20

Re: Couldn't add "network interface" in virt-manager

I have a similar error and I still didn't find any solution:
https://lists.fedorahosted.org/archives … 77TOIS4MF/

Offline

#3 2016-02-04 12:35:18

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,349
Website

Re: Couldn't add "network interface" in virt-manager

@darkbasic,

please don't bump old threads. You can always start a new one.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.

Offline

Board footer

Powered by FluxBB