You are not logged in.

#1 2013-01-24 17:12:52

cedricl
Member
Registered: 2012-10-16
Posts: 16

[SOLVED] slim v1.3.5-1: "failed to execute login command"

Hi,

After updated slim from v1.3.4-4 to v1.3.5-1 the default windows manager is not loaded and "failed to execute login command" appear.  After switching with <F1> key to the correct windows manager, it is loaded properly .
Using

 exec startxfce4 

into ~/.xinitrc instead of :

DEFAULT_SESSION=twm

case $1 in
xfce4)
	exec startxfce4
	;;
fluxbox)
exec startfluxbox
	;;
*)
	exec $DEFAULT_SESSION
	;;
esac

also start the default window manager.

I have downgraded slim to v1.3.4-4 and the issue did not appear anymore.

Do you think this is a misconfiguration or a bug ?

Thanks for your answer

/etc/slim.conf content :

# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth 

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
 login_cmd           exec /bin/sh -  ~/.xinitrc %session
# login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd	some command
# sessionstop_cmd	some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon	yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            xfce4,fluxbox

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session: 

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
default_user        cedric

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
auto_login          yes


# current theme, use comma separated list to specify a set to 
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log
This is some code.

~/.xinitrc

#!/bin/sh

# Enable special thinkpad keys
/usr/bin/tpb -d

# Activer .XCompose pour GTK
GTK_IM_MODULE=xim
export GTK_IM_MODULE

#export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

#exec startxfce4

# the following variable defines the session which is started if the user
# doesn't explicitely select a session
DEFAULT_SESSION=twm

case $1 in
xfce4)
	exec startxfce4
	;;
fluxbox)
exec startfluxbox
	;;
*)
	exec $DEFAULT_SESSION
	;;
esac

Last edited by cedricl (2013-01-25 13:39:57)

Offline

#2 2013-01-24 17:39:05

Chrishas
Member
Registered: 2012-11-03
Posts: 26

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Hi, I've got exactly the same issue after upgrading but using enlightenment. If I switch to gnome which is not the default session with F1 then it logs in correctly.

Offline

#3 2013-01-24 18:21:07

cedricl
Member
Registered: 2012-10-16
Posts: 16

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Hello.

Thanks for your comment.
And if you switch to enlightenment with F1 does it  work ?
For me it work too

Offline

#4 2013-01-24 21:02:00

plp
Member
Registered: 2013-01-24
Posts: 15

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Exactly the same happens to me with xfce. Downgrading slim to 1.3.4 fixes the problem.

Offline

#5 2013-01-24 21:34:08

cedricl
Member
Registered: 2012-10-16
Posts: 16

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

I made a bug report in the project hosting (bug #18875).
http://developer.berlios.de/bugs/?func= … up_id=2663

Offline

#6 2013-01-24 21:48:11

Chrishas
Member
Registered: 2012-11-03
Posts: 26

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Yes if I select gnome and then reselect enlightenment with F1 then it logs in.

Offline

#7 2013-01-25 13:37:11

cedricl
Member
Registered: 2012-10-16
Posts: 16

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Solved :
In v1.3.5 slim probably not preset any default session name unlike what is written in /etc/slim.conf (add "echo $1 > .var" in ./xinitrc create an empty file).
So slim try to start the default session from ./xinitrc, and in my case it's not configured properly... ("twm" is not installed)

So I change "DEFAULT_SESSION=twm"  to  "DEFAULT_SESSION=startxfce4" and it works.

Last edited by cedricl (2013-01-25 14:13:10)

Offline

#8 2013-01-25 17:43:30

plp
Member
Registered: 2013-01-24
Posts: 15

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

I can confirm that cedricl was right. Problem is solved here.

My .xinitrc:

DEFAULT_SESSION=startxfce4

case $1 in
xfce4)
	exec startxfce4
	;;
startx)
	exec twm
	;;
*)
	exec $DEFAULT_SESSION
esac

Offline

#9 2013-01-26 11:01:20

kaipee
Member
From: Belfast, UK
Registered: 2012-07-07
Posts: 200

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

plp wrote:

I can confirm that cedricl was right. Problem is solved here.

My .xinitrc:

DEFAULT_SESSION=startxfce4

case $1 in
xfce4)
	exec startxfce4
	;;
startx)
	exec twm
	;;
*)
	exec $DEFAULT_SESSION
esac

This is not correct, DEFAULT_SESSION= should be the 'tag' that you specified such as 'xfce4' or 'startx' which then executes the exec startxfce4 command.

Your xinitrc should look like:
DEFAULT_SESSION=xfce4

Not
DEFAULT_SESSION=startxfce4

This is still a bug (though this workaround does work)

Offline

#10 2013-01-26 12:35:55

cedricl
Member
Registered: 2012-10-16
Posts: 16

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

kaipee wrote:

Your xinitrc should look like:
DEFAULT_SESSION=xfce4

Not
DEFAULT_SESSION=startxfce4

This is still a bug (though this workaround does work)

Sorry kaipee but plp was right because default session is started with the command "exec $DEFAULT_SESSION" who can be translated in this case by exec startxfce4 and not exec xfce4. (DEFAULT_SESSION is not the variable 1)

Offline

#11 2013-09-15 13:53:58

mouni
Member
From: Azores
Registered: 2011-07-03
Posts: 15

Re: [SOLVED] slim v1.3.5-1: "failed to execute login command"

Greetings, Not working with me.

"failed to execute login command". But, If I log with the user root I can join in slim. others users are not allow.


"See, you not only have to be a good coder to create a system like Linux, you have to be a sneaky bastard too." - Linus Torvalds

Offline

Board footer

Powered by FluxBB