You are not logged in.

#1 2013-01-25 16:26:28

jash
Member
Registered: 2009-08-24
Posts: 10

[Solved] Problems with net-auto-wired, no interent after install

*Background*
I am returning to Arch Linux after being away for about a year. I have finally had a chance to install Arch on my new laptop. Since I am new to systemd and the new installation process I followed the beginners guide very closely.

*Description of the Steps I followed and the Error I encountered*
When I came the the "Configure the Network" Portion of the Beginners' Guide, I chose to follow the net-auto-wired setup. This was partly because I found the warning to be confusing and could not understand why the Guide included a command that "won't work". Additionally I the "net-auto-wired" method seemed given the language of the Guide to be the superior alternative. So I followed the following steps:

# pacman -S ifplugd
# cd /etc/network.d
# ln -s examples/ethernet-dhcp .
# systemctl enable net-auto-wired.service

These commands returned no errors, nor did the net-auto-wired daemon fail to initialize on reboot. I simply did not have a connection with the internet, even after confirming that all the wires were securely plugged in.

*Question for the Forum*
I was able to establish a connection with via several means as well I will likely be installing dbus and wicd to manage my internet connections. So my question is less about how to get connected and more (a) how to trouble shoot net-auto-wired and (b) what language and procedures can we change to the Beginners' Guide so that this issue is not encountered by beginners in the future.

*Information I have Uncovered*
When the net-auto-wired daemon failed to establish a connection. I immediately tried running the following command:

# systemctl enable dhcpcd@enp4s0f2.service

The output of this command (what is following) showed me what the warning was talking about, how it rename the symbolic link to eth0.service and not enp4s0f2.service as it should have.

  ln -s '/usr/lib/systemd/system/dhcpcd@.service' '/etc/systemd/system/multi-user.target.wants/dhcpcd@eth0.service'

I attempted to resolve this issue by creating the symbolic link with the following command

# ln -s /usr/lib/systemd/system/dhcpcd@.service /etc/systemd/system/multi-user.target.wants/dhcpcd@enp4s0f2.service

After reboot, the appropriately started the dhcpcd@ deamon and established an internet connection.
It also hit me that the netcfg profile "ethernet-dhcp" would be pointing to the wrong interface. I edited the profile to interface with the enp4s0f2 not eth0 and was able to establish a connection manually with the following command but net-auto-wired still failed to work.

# netcfg ethernet-dhcp

At this point I checked the status of the of the net-auto-wired daemon with the following command which uncovered what is most certainly the issue.

# systemctl status net-auto-wired
  net-auto-wired.service - Provides automatic netcfg wired connection
	Loaded: loaded (/usr/lib/systemd/system/net-auto-wired.service; disabled)
	Active: active (running) since Thu 2013-01-24 14:47:12 EST; 36s ago
	Main PID: 421 (ifplugd)
	CGroup: name=systemd:/system/net-auto-wired.service
		421 /usr/bin/ifpluged -i eth0 -r /etc/ifplugd/netcfg.action -fIns

  Jan 24 14:47:12 ragnarok systemd[1]: Started Provides automatic netcfg wired connection.
  Jan 24 14:47:12 ragnarok ifplugd[421]: ifplugd 0.28 initializing.
  Jan 24 14:47:12 ragnarok ifplugd[421]: Using interface eth0
  Jan 24 14:47:12 ragnarok ifplugd[421]: Initalization complete, link beat not detected. 

Obviously the issues with this are it use of eth0 and not enp4s0f2.

I do not know where to go from here but I am curious if the issue of dhcpcd@ misnaming the symlink is some how related to this issue.

Thanks for all your insight and responses.


PS. This is the third time I have written this post. I finally typed it out in a separate text editor and then copied it in. Twice my login has timed out before I could submit and thus when I submitted I was logged out and my post lost. I do not post often with the forums but I was just frustrated to have lost so much effort. Has anyone else encountered this?

Last edited by jash (2013-01-25 17:29:49)

Offline

#2 2013-01-25 16:42:56

chris_l
Member
Registered: 2010-12-01
Posts: 387

Re: [Solved] Problems with net-auto-wired, no interent after install

So, you have set enp4s0f2 on /etc/conf.d/netcfg, right?

About the forum, no, it let me stay connected until I click Logout.


"open source is about choice"
No.
Open source is about opening the source code complying with this conditions, period. The ability to choose among several packages is just a nice side effect.

Offline

#3 2013-01-25 16:55:18

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,304

Re: [Solved] Problems with net-auto-wired, no interent after install

jash wrote:

PS. This is the third time I have written this post. I finally typed it out in a separate text editor and then copied it in. Twice my login has timed out before I could submit and thus when I submitted I was logged out and my post lost. I do not post often with the forums but I was just frustrated to have lost so much effort. Has anyone else encountered this?

Yes, it seems that after a period of inactivity (5 minutes ?) the forum software automatically logs someone out.

After that happened to me for the zillionth time, i installed the firefox addon ReloadEvery .
Now i always open 2 tabs for arch forums : 1 that just shows the index, and has reloadevery enabled with a time of 1 minute.
The 2nd tab is for reading/answering etc.
Haven't been logged out automatically since.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2013-01-25 17:02:28

jash
Member
Registered: 2009-08-24
Posts: 10

Re: [Solved] Problems with net-auto-wired, no interent after install

Thank you very much chris_I and Lone_Wolf

@chris_I
No I had not edited that config. My first time working with netcfg and I was unaware of it. I did so and now it is working correctly. Perhaps this should be added the the net-auto-wired portion of the Beginners Guide, at least as a contingency to your device not being eth0.
After changing that config net-auto-wired is working well.

@Lone_Wolf
An intriguing work around I will look into that myself.

Thank you both for your replies.

Offline

#5 2013-02-06 17:06:13

Kobussie
Member
From: NL - Limburg
Registered: 2007-04-06
Posts: 41
Website

Re: [Solved] Problems with net-auto-wired, no interent after install

Thanks, jash,

Your

*Information I have Uncovered*

helped me to get an internet connection after a new install!

Offline

Board footer

Powered by FluxBB