You are not logged in.

#1 2013-01-25 19:58:21

jamtat
Member
Registered: 2008-03-13
Posts: 175

[solved] Start X at Login not working for me

I'm stripping down my system and decided to get rid of my login manager (slim) and just make the system boot straight into the GUI on boot-up. I followed directions found at https://wiki.archlinux.org/index.php/St … sh_profile , but it's not working on this system. I just get dumped at a command prompt login when I reboot the system and, after having logged in, no X gets started. The system just sits there awaiting input at the prompt. If I enter startx, the GUI starts. But it's not starting at login as I'd like. Actually, it'd be even better if the system automatically logged me in and started X--like we used to do using inittab, once, etc. But that method's obviated now because of systemd, no? My WM is jwm, by the way. Tips on resolving this issue will be appreciated.

James

Last edited by jamtat (2013-01-25 21:59:42)

Offline

#2 2013-01-25 20:25:52

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,631

Re: [solved] Start X at Login not working for me

You can still set up automatic login ("like we used to do using inittab, once, etc"): https://wiki.archlinux.org/index.php/Au … al_console

As for your original question, I assume you are using bash, and you have added the correct information to your ~/.bash_profile? ("but it's not working on this system" is a little vague). This works for me.

[[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && exec startx

Last edited by 2ManyDogs (2013-01-25 20:31:30)

Offline

#3 2013-01-25 21:04:32

jamtat
Member
Registered: 2008-03-13
Posts: 175

Re: [solved] Start X at Login not working for me

Thanks for your reply, 2ManyDogs. I actually managed to find that page while further researching this matter. It turned out that part of my problem had to do with dbus and the new systemd stuff on this newly-updated machine. Once I entered the right parameters in my grub file (init=/usr/lib/systemd/systemd) to make systemd run at boot-up, then applied the modifications given at that site, I was able to get the system to automatically log me in and boot to a GUI. So i can confirm that it works. And yes, I did enter the specified line into .bash_profile; but without systemd running, it seems that doesn't work.

James

Offline

#4 2013-01-25 21:10:16

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,631

Re: [solved] Start X at Login not working for me

Ah, yes, the wiki assumes everyone is running systemd at this point. If you have it working now, please mark your thread [SOLVED] (edit the title of your first post). If you have not yet fully updated to systemd (so that boot parameter is no longer required) you might want to consider doing it now.

Last edited by 2ManyDogs (2013-01-25 21:14:19)

Offline

#5 2013-01-25 21:59:22

jamtat
Member
Registered: 2008-03-13
Posts: 175

Re: [solved] Start X at Login not working for me

Well, I obviously have more study to do here, 2ManyDogs: I thought adding that boot parameter was the final step in the process. I'll see what further steps I can turn up on that. Meantime, I'll go ahead and mark this thread solved (I have another desktop query, but it's on a different topic, so I'll start a new thread for that).

Offline

#6 2013-01-25 22:01:30

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,631

Re: [solved] Start X at Login not working for me

Thanks for marking it [solved]. For more about migrating to systemd, read this section of the systemd wiki page: https://wiki.archlinux.org/index.php/Sy … stallation (once you remove initscripts and sysvinit from your system and install systemd-sysvcompat, you no longer need that boot parameter).

Last edited by 2ManyDogs (2013-01-25 22:03:19)

Offline

#7 2013-01-25 22:22:33

jamtat
Member
Registered: 2008-03-13
Posts: 175

Re: [solved] Start X at Login not working for me

Thanks much for that pointer, 2ManyDogs. You just shaved at least an hour off my current ongoing system rescue marathon.

James

Offline

Board footer

Powered by FluxBB