You are not logged in.

#1 2013-01-29 18:04:50

Registered: 2011-06-03
Posts: 10

[Solved] MPlayer interrupted by signal 6 in module: key_events

Hi everyone.

I have a fresh and updated installation. (After 1 month without using a PC. XD)
The problem is, every time I tried to play something with mplayer2, it crash with the message shown below. While mplayer (version 1) seems to work fine.

mplayer --msglevel=global=8 Vídeos/Toki\ wo\ Kakeru\ Shoujo\ \[Fached\].mkv 
MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
get_path('codecs.conf') -> '/home/rockrknight/.mplayer/codecs.conf'
get_path('fonts') -> '/home/rockrknight/.mplayer/fonts'
get_path('fonts') -> '/home/rockrknight/.mplayer/fonts'
get_path('fonts') -> '/home/rockrknight/.mplayer/fonts'
get_path('subfont.ttf') -> '/home/rockrknight/.mplayer/subfont.ttf'
get_path('input.conf') -> '/home/rockrknight/.mplayer/input.conf'
get_path('Toki wo Kakeru Shoujo [Fached].mkv.conf') -> '/home/rockrknight/.mplayer/Toki wo Kakeru Shoujo [Fached].mkv.conf'

Playing Vídeos/Toki wo Kakeru Shoujo [Fached].mkv.
get_path('sub/') -> '/home/rockrknight/.mplayer/sub/'
Cache size set to 8192 KiB
Cache fill:  0.00% (0 bytes)   

[mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "ignaciogb - Toki wo Kakeru Shoujo", -vid 0
[mkv] Track ID 2: audio (A_AC3) "Japones - 5.1", -aid 0, -alang jpn
[mkv] Track ID 3: subtitles (S_TEXT/UTF8) "Español", -sid 0, -slang spa
[mkv] Will play video track 1.
Detected file format: Matroska
get_path('fonts') -> '/home/rockrknight/.mplayer/fonts'
get_path('subfont.ttf') -> '/home/rockrknight/.mplayer/subfont.ttf'
Load subtitles in Vídeos/
get_path('sub/') -> '/home/rockrknight/.mplayer/sub/'
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
Selected video codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 [libavcodec]
Selected audio codec: ATSC A/52A (AC-3) [libavcodec]
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
No bind found for key 'JOY_LEFT-JOY_AXIS2_PLUS'.
VIDEO:  1920x1080  23.976 fps    0.0 kbps ( 0.0 kB/s)
VO: [gl] 1920x1080 => 1920x1080 Planar YV12 
A:  -0.0 V:   0.0 A-V: -0.001 ct:  0.000   0/  0 ??% ??% ??,?% 0 0 98% 

MPlayer interrupted by signal 6 in module: key_events
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

It happens with music and video (mp3,oga,mp4,mkv,m2ts,avi,etc..). With pulseaudio installed, configured and working fine.

Both with free and propietary ATI drivers... FTW I have a laptop HP "g4-2205la" with an APU processor.

AMD A6-4400M APU with Radeon(tm) HD Graphics
Advanced Micro Devices [AMD] nee ATI Trinity [Radeon HD 7520G]

With the following:

catalyst/catalyst-hook 13.1-1 [installed]
catalyst/catalyst-utils 13.1-1 [installed]

But I'm not sure if the hardware have something to do with it.
Unfortunately I don't have any other computer to try it out. I'd appreciate if someone can confirm this is a bug, so it could be reported.
Or is it a bad configuration? As I said before, mplayer version 1 is playing those files as usual.

Last edited by RockrKnight (2013-03-11 02:07:50)


#2 2013-03-11 02:07:24

Registered: 2011-06-03
Posts: 10

Re: [Solved] MPlayer interrupted by signal 6 in module: key_events

I "solved" this installing mplayer2-build-git from AUR


Board footer

Powered by FluxBB