You are not logged in.

#1 2013-01-30 22:41:23

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

[SOLVED] How to ignore glibc dependecy when I want to keep old glibc?

I'm porting Arch Linux to sh4 CPU.
But, at current stage, I want to use glibc,kernel of original distrubition's packages.
So, is there any method to let pacman ignore it?  I've tried IgnorePkg setting on /etc/pacman.conf, but failed.

 $ sudo pacman -U pacman-4.0.3-5-sh4.pkg.tar.xz
[sudo] password for dlin: 
loading packages...
resolving dependencies...
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc>=2.15", a dependency of "pacman"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "zlib"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "bzip2"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "expat"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "libgpg-error"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "pth"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "perl"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "gawk"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "libksba"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "readline"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "gdbm"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "libcap"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc>=2.17", a dependency of "gcc-libs"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "util-linux"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "pam"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "cracklib"
warning: ignoring package glibc-2.17-3
warning: cannot resolve "glibc", a dependency of "libgssglue"
:: The following package cannot be upgraded due to unresolvable dependencies:
      pacman

Do you want to skip the above package for this upgrade? [y/N] 

Last edited by dlin (2013-01-31 04:12:24)


Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

#2 2013-01-31 00:04:09

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,408
Website

Re: [SOLVED] How to ignore glibc dependecy when I want to keep old glibc?

You can create a dummy package.  Just run makepkg on this:

pkgname=glibc
pkgver=2.17
pkgrel=3
arch=('any')

Offline

#3 2013-01-31 04:10:52

dlin
Member
From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

Re: [SOLVED] How to ignore glibc dependecy when I want to keep old glibc?

Thanks your great trick.


Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,

Offline

Board footer

Powered by FluxBB