You are not logged in.

#1 2013-02-01 14:07:20

apenney
Member
Registered: 2013-02-01
Posts: 3

Lenovo W530 no longer boots since updating past 3.7.1

Hi,

I've been suffering from this for a while and I finally thought I should get around to asking the collective wisdom of the forums.  I use rEFInd to boot my laptop and everything has been working well until I updated to 3.7.3.  The next time I rebooted it got to the rEFInd menu and let me select the kernel but write after it writes out the line about what kernel/initrd it's writing it completely hangs.  No console, no network, nothing.  I can't get it to panic either, it just sits there uselessly mocking me.

I've since tried several other versions of rEFInd, switched to gummiboot, switched back, tried 3.7.4 and 3.7.5 and nothing has helped other than reverting the kernel package.  Has anyone seen anything similar or have any ideas on what I can try?  My only thought at this point is to wait for a 3.8 package and try again and pray it magically works.  It's very frustrating as I can get very limited debug information due to the way it just freezes up as soon as it gets past rEFInd.  I thought maybe the efi stub stuff was broken but I wouldn't know where to look/how to fix that.

Any suggestions greatly appreciated.

Offline

#2 2013-02-03 05:04:44

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: Lenovo W530 no longer boots since updating past 3.7.1

I'd recommend manually copying the boot files back to to the EFI partition.  Always eliminate the simplest possibility first.

Offline

#3 2013-02-03 20:41:44

apenney
Member
Registered: 2013-02-01
Posts: 3

Re: Lenovo W530 no longer boots since updating past 3.7.1

I did try that.  I manually copied back over the 3.7.1 kernel upon reinstalling the package to confirm that it would work.  I manually copied each of the pieces on each refind upgrade (in case) as well as when setting up gummiboot.

Offline

Board footer

Powered by FluxBB