You are not logged in.

#1 2013-02-03 16:19:35

Registered: 2008-10-17
Posts: 7

LMMS "Mallets" Question - STK not installed correctly?

Not sure if I should go here, or to the LMMS folks, but when I'm using LMMS (which so far works correctly), I get an error when trying to use the "Mallets" instrument, saying:

"Missing Files" - Your Stk-installation seems to be incomplete. Please make sure the full Stk-package is installed!

I've verified that I'm up to date with Stk, 4.4.4-1 installed.

Based on my quick googling of the issue, it looks like that error is triggered if there are missing files.  (Makes sense, given the box header).

Anyone have any thoughts on this?


#2 2013-02-08 02:11:34

From: Milton, Ontario, Canada
Registered: 2012-05-25
Posts: 1

Re: LMMS "Mallets" Question - STK not installed correctly?

In LMMS go to Edit -> Settings and click on the Paths tab.

Change the path to STK Rawwave Directory to /usr/lib/stk/rawwaves

Worked for me.


#3 2015-01-29 12:22:28

Registered: 2015-01-29
Posts: 7

Re: LMMS "Mallets" Question - STK not installed correctly?

This question is old, but it seems the problem still exists, and can't be solved by the method pointed. Directory /usr/lib/stk/rawwaves does not even exist. /usr/share/stk/rawwaves also don't exist. I used "pacman -Ql stk" to see stk installed files and theres no folder named rawwaves anywhere. How can I solve this problem now?


#4 2015-01-29 17:54:10

Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,601

Re: LMMS "Mallets" Question - STK not installed correctly?

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438


Board footer

Powered by FluxBB