You are not logged in.

#1 2013-02-03 20:47:53

From: IT
Registered: 2009-06-13
Posts: 370

[solved by magic] Can't mount btrfs drive

For 'historical reasons' my home drive is in btrfs.  My computer froze and I had to force off the power.  Unfortunately, now I cannot mount my brtfs drive.  When I boot my computer systemd send me to recovery mode.  All other drives appear to be working.  When I try mount it just says

[80.898989] devide dsid 0df53e5f-49a0-4efc.... devid 1 transid 173449 /dev/sda3

and nothing further happens.

I have tried to run brtfs --repair and brtfsck on the drive without it giving me any particularly informative output.  I checked the drive with the bios hdd software, and it didn't report any errors.

I have some unpushed changes for a thing I need to present tomorrow, so any help would be appreciated.


edit: I restarted my machine after having run the two mentioned commands and it booted/mounted again.  I don't know exactly what happened?

Last edited by Pank (2013-02-03 21:48:33)

Arch x64 on Thinkpad X200s/W530


Board footer

Powered by FluxBB