You are not logged in.

#1 2013-02-04 06:55:49

Registered: 2012-01-30
Posts: 9

Non-root authentication problem-system is booting up (found solution)

This is in reference to
Since that thread is marked solved and is getting a little moldy, I thought it more appropriate to start a new thread.
Today once again, I had the issue, that is, when sudo gets upgraded, it stops working and after a reboot when I try to ssh back into my embedded device I get nothing but the "system is booting up" message forever.
I can't believe none of us thought of it before, but today I have solved the issue once & for all.  No more replacing pam & pambase, messing up who knows what.
Because I know whenever sudo is upgraded it's probably going to mess up, I watch for it on upgrades.  Today when it upgraded I checked before reboot and sure enough, no more sudo.  I had a thought, perhaps it's just the password that is messed up.  So I ran passwd, re-input my password and sure enough, problem solved.  Rebooted like nothing ever happened and sudo works fine.
Granted, I think there is something a little funny with my installation causing this problem, but with this fix it's quite livable.


Board footer

Powered by FluxBB