You are not logged in.

#1 2013-02-05 13:09:04

From: Catanzaro, Italy
Registered: 2012-04-16
Posts: 25

[NOT SOLVED] Can't load Nvidia module at boot

Hi guys,
I've got some problem with graphic drivers.
I own a x53s series Asus laptop, mounting a Nvidia Geforce GT520MX together with an Intel HD Graphics 3000, so I must use Bumblebee drivers to make my Nvidia VGA work.
I added the following line in /etc/modules-load.d/nvidia.conf:

#loads nvidia module at boot

This is my /etc/bumblebee/bumblebee.conf:

## Server options. Any change made in this section will need a server restart
# to take effect.
# The secondary Xorg server DISPLAY number
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
# The name of the Bumbleblee server group name (GID name)
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)

## Client options. Will take effect on the next optirun executed.
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing and the
# default Xorg modules path

I can't understand why nvidia module isn't loaded after the boot.
When I type "lsmod | grep nvidia" I just don't receive any output, and when I add it manually via "modprobe nvidia" it appears in modules list for just a couple of minutes. What can I do?

Last edited by fabrydrunk (2013-02-18 00:52:16)


#2 2013-02-05 14:08:34

From: New York, USA
Registered: 2009-10-22
Posts: 4,109

Re: [NOT SOLVED] Can't load Nvidia module at boot

Sounds like it loads, and then something (bumblebee) unloads it. You can check dmesg for signs of it being loaded.


#3 2013-02-05 15:24:02

From: Catanzaro, Italy
Registered: 2012-04-16
Posts: 25

Re: [NOT SOLVED] Can't load Nvidia module at boot

$ Dmesg | grep nvidia

[    9.326230] nvidia: module license 'NVIDIA' taints kernel.
[    9.333733] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[   15.616928] bbswitch: device 0000:01:00.0 is in use by driver 'nvidia', refusing OFF
[   17.171490] nvidia 0000:01:00.0: power state changed by ACPI to D0

$ Dmesg | grep bbswitch

[   15.616807] bbswitch: version 0.5
[   15.616815] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   15.616822] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEGR.GFX0
[   15.616921] bbswitch: detected an Optimus _DSM function
[   15.616928] bbswitch: device 0000:01:00.0 is in use by driver 'nvidia', refusing OFF
[   15.616930] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[   15.620043] bbswitch: disabling discrete graphics
[   32.000221] bbswitch: disabling discrete graphics


#4 2013-02-05 15:38:39

From: Catanzaro, Italy
Registered: 2012-04-16
Posts: 25

Re: [NOT SOLVED] Can't load Nvidia module at boot

Anyway when I try to run

$ nvidia-settings

it shows me this advice: You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.


Board footer

Powered by FluxBB