You are not logged in.

#1 2013-02-07 01:26:10

From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 264

[SOLVED] check pacman source sign failed on sh4 CPU

I've build 'base' packages on sh4 CPU. (Some base library still use the original linux distributions. eg. gcc,glibc,...)

I followed Pacman-key to setup key rings.

pacman-key --init
pacman-key --populate archlinux
pacman-key --refresh-keys

I run previous commands through ssh.  I tried to build haveged, but it occurs following messages, I guess it is caused by old kernel and my hardware haven't realtime clock. So I forgive it.

gcc -Wall -I.. -O2 -pipe   -o haveged haveged.o havege.o havegetune.o havegecollect.o havegetest.o
havegecollect.o: In function `havege_gather':
havegecollect.c:(.text+0x264): undefined reference to `HARDCLOCK'
havegecollect.c:(.text+0x6a0): undefined reference to `HARDCLOCK'
havegecollect.c:(.text+0x9d0): undefined reference to `HARDCLOCK'
havegecollect.c:(.text+0xd8c): undefined reference to `HARDCLOCK'
havegecollect.c:(.text+0x1208): undefined reference to `HARDCLOCK'
havegecollect.o:havegecollect.c:(.text+0x1684): more undefined references to `HARDCLOCK' follow
collect2: ld returned 1 exit status

And rerun makepkg on pacman.

==> Validating source files with md5sums...
    pacman-4.0.3.tar.gz ... Passed
    pacman-4.0.3.tar.gz.sig ... Passed
    0001-Add-conflict-for-replacing-owned-empty-directory.patch ... Passed
    0002-Check-empty-subdirectory-ownership.patch ... Passed
    0003-Ensure-pre_upgrade-scriptlet-gets-old-package-version.patch ... Passed
    pacman.conf ... Passed
    pacman.conf.x86_64 ... Passed
    pacman.conf.sh4 ... Passed
    makepkg.conf ... Passed
==> Verifying source file signatures with gpg...
    pacman-4.0.3.tar.gz ... FAILED (unknown public key 5C2E46A0F53A76ED)
==> WARNING: Warnings have occurred while verifying the signatures.
    Please make sure you really trust them.

Even I manual add the key on message, it is still failed.

$ sudo pacman-key -r 5C2E46A0F53A76ED
gpg: requesting key F53A76ED from hkp server
gpg: key F53A76ED: "Dan McGee <>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
==> Updating trust database...
gpg: next trustdb check due at 2014-01-22

$ makepkg
==> Verifying source file signatures with gpg...
    pacman-4.0.3.tar.gz ... FAILED (unknown public key 5C2E46A0F53A76ED)

BTW, in the process of building gpgme, I can not build pinentry successful, so I pass and use fedora's.

fedora9 pinentry 0.7.4-5.fc9.sh4

Solved, I guess wrong direction, that's cause I forgot to read Makepkg again.

gpg --list-keys
echo 'keyring /etc/pacman.d/gnupg/pubring.gpg' >> ~/.gnupg/gpg.conf

Last edited by dlin (2013-02-07 01:42:56)

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,


Board footer

Powered by FluxBB