You are not logged in.

#1 2013-02-07 04:30:10

From: Taipei,Taiwan
Registered: 2005-09-21
Posts: 265

[Solved] How to solve ./configure finding wrong db version?

I'm building 'serf' on sh4 CPU.
I was use fedora's db4 package ( db4 4.6.21-7.fc9.sh4).
After successful build Arch's db 5.3.21-1, I rebuild 'serf' by makepkg.

configure: creating ./config.status  
config.status: creating Makefile
config.status: creating serf.pc
config.status: executing mkdir-vpath commands
/usr/share/apr-1/build/libtool --silent --tag=CC --mode=link gcc -L/usr/lib -R/u
sr/lib  -rpath /usr/lib -o buckets/aggregate_buckets.lo buckets/req
uest_buckets.lo context.lo buckets/buckets.lo buckets/simple_buckets.lo buckets/
file_buckets.lo buckets/mmap_buckets.lo buckets/socket_buckets.lo buckets/respon
se_buckets.lo buckets/headers_buckets.lo buckets/allocator.lo buckets/dechunk_bu
ckets.lo buckets/deflate_buckets.lo buckets/limit_buckets.lo buckets/ssl_buckets
.lo buckets/barrier_buckets.lo buckets/chunk_buckets.lo buckets/bwtp_buckets.lo 
buckets/iovec_buckets.lo incoming.lo outgoing.lo ssltunnel.lo auth/auth.lo auth/auth_basic.lo auth/auth_digest.lo auth/auth_kerb.lo auth/auth_kerb_gss.lo -lm    /usr/lib/ -lldap -llber -ldb-5.3 -lgdbm  -lexpat /usr/lib/ -luuid -lrt -lcrypt -lpthread -ldl -lm -lz -lssl -lcrypto
/usr/bin/grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file or directory
libtool: link: `/usr/lib/' is not a valid libtool archive
make: *** [] Error 1
==> ERROR: A failure occurred in build().

It seems I've installed a old apr-util, I'll try rebuild  apr-util.

grep 4.6 /usr/lib/*la
/usr/lib/' -lcrypt -lldap -llber /usr/lib/ -lexpat /usr/lib/ -lpthread -ldl'

After remove that file and it works now.

Last edited by dlin (2013-02-07 05:37:14)

Running 4 ArchLinux including sh4twbox,server,notebook,desktop. my AUR packages, old project Arch on colinux,


Board footer

Powered by FluxBB