You are not logged in.

#1 2013-02-07 13:19:52

From: /ukraine/kyiv
Registered: 2008-09-12
Posts: 82

Mounting netatalk afp share fails


I'm using netatalk on Ubuntu server to maintain file sharing service for Macs, but also want to connect to it using my Arch laptop.

Macs connect to share OK, there are no problems at all, but my Arch fails to do the same thing.

On my laptop I get:

[pf@spock]:[~/work/remotes][0]% mount serv_soft        
Unknown option noexec, skipping
Unknown option nosuid, skipping
Unknown option nodev, skipping
The afpfs daemon does not appear to be running for uid 1000, let me start it for you
Mounting from Soft on /home/pf/work/remotes/serv_soft
Login error: Unknown error, maybe username/passwd needed?

journalctl gives me the following:

лют 07 15:11:54 spock [27466]: Starting up AFPFS version 0.8.1
лют 07 15:11:55 spock [27466]: Libgcrypt warning: missing initialization - please fix the application

/etc/fstab contains the following line:

afpfs#afp://xxxxx:yyyyy@ /home/pf/work/remotes/serv_soft fuse user,noauto 0 0

/etc/fuse.conf contains only this line:


Server logs are not too informative:

Feb  7 15:11:26 serv afpd[19522]: AFP3.2 Login by xxxxx
Feb  7 15:11:26 serv afpd[19522]: dsi_stream_read: len:0, unexpected EOF
Feb  7 15:11:26 serv afpd[19522]: dsi_disconnect: entering disconnected state

Any ideas on what should be done to fix that?

Linux spock 4.4.0-pf1 #1 SMP PREEMPT Mon Jan 18 11:03:05 UTC 2016 x86_64 GNU/Linux


Board footer

Powered by FluxBB