You are not logged in.

#1 2013-02-07 20:18:11

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 453

[solved] how can I launch Deadbeef minimised to tray?

Hi.... I currently have deadbeef launch in my openbox autostart script, and it starts playing, has a tray icon, but the gui jumps up to. I then have to close the gui, and it minimises to the tray. I want to find a way of skipping the last step.... either have deadbeef launch minimised, or a command to close deadbeef in the same way that clicking the X does..... not had much joy with google.... maanged to get this to work with transmission, as it has a "-m" argument.

Last edited by ninjaprawn (2013-02-08 10:10:14)


Arch Linux on 4 machines - all vnc'ed and samba'ed - Asus 1001px
- P4 2.8GHz, 1Gb ram, GeForce6200, 290Gb (media centre)(no keyboard or mouse)
- HP Pavilion G6 Dual core 2.2GHz, 4Gb ram, 750Gb
- Samsung Series 3, i5, 6g ram, 750gb

Offline

#2 2013-02-07 20:38:29

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,631

Re: [solved] how can I launch Deadbeef minimised to tray?

Can you set properties for DeadBeef in rc.xml? Of course if you do this, DeadBeef will always open minimized...

http://openbox.org/wiki/Help:Applications

Online

#3 2013-02-07 21:09:22

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 453

Re: [solved] how can I launch Deadbeef minimised to tray?

yes, i can set properties for deadbeef in rc.xml however I am not sure how to set this for deadbeef to start up in the tray only.... the closest option is to start it iconified, which isnt what I am after........

after a lot of googling, there isnt a direct way to get deadbeef to do this.... what i need is the following;
deadbeef /my/playlist.pls && <some command> deadbeef

where <some command> has the same effect as clicking the x on deadbeef


Arch Linux on 4 machines - all vnc'ed and samba'ed - Asus 1001px
- P4 2.8GHz, 1Gb ram, GeForce6200, 290Gb (media centre)(no keyboard or mouse)
- HP Pavilion G6 Dual core 2.2GHz, 4Gb ram, 750Gb
- Samsung Series 3, i5, 6g ram, 750gb

Offline

#4 2013-02-08 01:06:31

dag
Member
From: US
Registered: 2013-01-20
Posts: 216

Re: [solved] how can I launch Deadbeef minimised to tray?

install wmctrl and then make shellscript

#!/bin/sh
deadbeef  &
sleep 3
wmctrl -c deadbeef

make it executable and autostart


--------------------------------------
alcoves wonder creates the wonder unto the ages; never lose that.

Offline

#5 2013-02-08 10:09:43

ninjaprawn
Member
From: Manchester, UK
Registered: 2008-01-26
Posts: 453

Re: [solved] how can I launch Deadbeef minimised to tray?

dag wrote:

install wmctrl and then make shellscript

#!/bin/sh
deadbeef  &
sleep 3
wmctrl -c deadbeef

make it executable and autostart

perfect.... i just changed the line in my autostart to ....
deadbeef /my/playlist.pls && wmctrl -c deadbeef &

i saw this somewhere else, but there was no mention of installing wmctrl... thanks smile


Arch Linux on 4 machines - all vnc'ed and samba'ed - Asus 1001px
- P4 2.8GHz, 1Gb ram, GeForce6200, 290Gb (media centre)(no keyboard or mouse)
- HP Pavilion G6 Dual core 2.2GHz, 4Gb ram, 750Gb
- Samsung Series 3, i5, 6g ram, 750gb

Offline

Board footer

Powered by FluxBB