You are not logged in.

#1 2013-02-07 22:55:25

Registered: 2013-01-13
Posts: 8

[SOLVED] Inconsistent Authentication Error

My password is not working for my regular account. I can log in (using the Gnome authentication manager) using my password, but once I have logged in the password does not work.
If I log in as root, I can use passwd to change the password of the user account without errors. However, if I su to the user account, nothing has changed; the password still does not work. E.g., see the following terminal dialogue:

[root@machine ~]$ passwd user                     
New UNIX password: [user_password]                     <-- successfully change user's password
[root@machine ~]$ su user
[user@machine ~]$ passwd
(current) UNIX password: [user_password]              <-- same as was just set without error by root
passwd: Authentication failure
passwd: password unchanged                                  <-- password does not work as user
[user@machine ~]$ su root
Password: [root_password]
su: Authentication failure                                          <-- root password does not work either

Oddly, I can still log in using the Gnome authentication manager, but if I lock the screen with Gnome then I can't log back in.

Some information about my system that may be pertinent:
- I'm using GNOME 3 in fallback mode
- I just restored my Arch install from a clone of the root partition; the problem is new since then.
- [EDIT] I already tried booting from the live CD, chrooting, and resetting the password, but it didn't work.

Thanks in advance!

Last edited by brunnels (2013-02-10 05:47:33)


#2 2013-02-10 05:34:58

Registered: 2013-01-13
Posts: 8

Re: [SOLVED] Inconsistent Authentication Error

Problem solved. This was the result of messing up the permissions of the files when I copied them over from my hard disk.

For future reference: whenever using cp to back up a partition, be sure to use the -a flag which preserves permissions!

[Partial] solution: Run the following commands:
chown root:root /usr/bin/sudo     <---- make sure root owns sudo
chmod 4111 /usr/bin/sudo          <---- set correct permissions *and* set the uid bit to 1
chmod 4111 /bin/su                    <---- same for su

Unfortunately there is no way to completely solve the problem of messing up permissions. Fortunately in this case, everything is still fairly functional; future problems may need to be resolved by changing ownership problems.


Board footer

Powered by FluxBB