You are not logged in.

#1 2013-02-09 05:51:11

llawwehttam
Member
From: United Kingdom
Registered: 2010-01-19
Posts: 180
Website

Wine, Eve Online and Pulseaudio

I've got Eve Online working nicely in Wine with very few problems. However I can't get it to work nicely with pulseaudio.

Winecfg's audio section can play sound through pulseaudio just fine, via alsa using ~/.asoundrc. However Eve Online cannot output sound while pulse is running and so I have to use pasuspender when running Eve.
I've googled quite a bit and tried several solutions. However they all seem out of date or require compiling custom versions of wine with patches that may or may not work with newer version of wine.

It's a bit annoying as I'd like to be able to listen to my music while playing.

Any ideas?


NERD in Training :: Please be Gentle tongue

Offline

#2 2013-02-09 06:40:49

t0m5k1
Member
From: overthere
Registered: 2012-02-10
Posts: 310

Re: Wine, Eve Online and Pulseaudio

just a thought but have you tried suffixing your run line for eve online with -dsound, thus:

WINEPREFIX="<path/to/eve-online/prefix/>" wine "C:\<path\to\eve-online\executable.exe" -dsound

I had the same problem with another game & tried everything then found this & it resolved the issue for me


Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - AwesomeWM (occasionally XFCE, i3)

If everything in life was easy, we would learn nothing!
Linux User: 401820   Last FM

Offline

#3 2013-02-09 07:31:30

brebs
Member
Registered: 2007-04-03
Posts: 3,468

Re: Wine, Eve Online and Pulseaudio

Offline

#4 2013-02-09 07:31:48

llawwehttam
Member
From: United Kingdom
Registered: 2010-01-19
Posts: 180
Website

Re: Wine, Eve Online and Pulseaudio

t0m5k1 wrote:

just a thought but have you tried suffixing your run line for eve online with -dsound, thus:

WINEPREFIX="<path/to/eve-online/prefix/>" wine "C:\<path\to\eve-online\executable.exe" -dsound

I had the same problem with another game & tried everything then found this & it resolved the issue for me

I'm not using a WINEPREFIX as eve is the only thing I will ever use in wine. Sadly -dsound had absolutely no effect for me.

brebs wrote:

I looked for ages for the package wine-pulse and didn't twig that the name had changed til after I started this thread.

Almost finished compiling so I'll give it a shot and report back.

EDIT: Will it use pulseaudio by default?

Last edited by llawwehttam (2013-02-09 07:40:21)


NERD in Training :: Please be Gentle tongue

Offline

#5 2013-02-09 08:13:56

llawwehttam
Member
From: United Kingdom
Registered: 2010-01-19
Posts: 180
Website

Re: Wine, Eve Online and Pulseaudio

Well wine-multimedia worked very well. It's clearly got a few bugs still but on the whole not bad at all.  Wine-multimedia does trigger a graphics issue (using the captains quarters causes a crash), whereas wine does not, but that is a known issue with the game and is affecting some windows users too.

Sound works very well, it was choppy for a few seconds as the game started but fine after that. Funnily enough it feels faster and much smoother than on my windows install.

EDIT: For anyone else setting up eve as well it seems the client and the launcher need some different settings. I made two aliases:

eve='WINEDLLOVERRIDES="*msvcrt,*msvcr100,*msvcr90,*msvcr80=b,n" wine "C:\Program Files (x86)\CCP\EVE\bin\ExeFile.exe"'
eve-launcher='WINEDLLOVERRIDES="*msvcr100,*msvcr90,*msvcr80=n,b" wine "C:\Program Files (x86)\CCP\EVE\eve.exe"'

Seems to do the trick.

### A few things I've learned doing this: ###

You need to install winetricks and run:

winetricks corefonts d3dx9_36 vcrun2005 vcrun2008 vcrun2010

Before running the eve setup.
If vcrun2010 fails try running winetricks msxml3 and follow the instructions to manually download the installer.

If you're client crashes on clicking on a character, open the game, log in, press escape, go to the graphics options and disable "Load Station Environment". Undock then change the option back. You should now have a movable station environment. If you were getting the crash before do NOT open the captain's quarters.

Using wine-multimedia you may have to use winecfg to change the audio out/in puts to pulseaudio.

Last edited by llawwehttam (2013-02-09 08:34:39)


NERD in Training :: Please be Gentle tongue

Offline

Board footer

Powered by FluxBB