You are not logged in.

#1 2013-02-10 21:11:41

ill
Member
From: US
Registered: 2011-06-22
Posts: 115

[SOLVED] No Wireless Networks Shown

Got a new laptop with the Intel Centrino Advanced-N 6235 - 802.11A/B/G/N Wireless LAN chipset, Arch automatically detects the correct chipset and selects the iwlwifi module. Everything seems great but when I scan for networks with wicd nothing shows up. Ideas?

Last edited by ill (2013-02-11 02:29:32)

Offline

#2 2013-02-10 21:17:09

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] No Wireless Networks Shown

I have this card.  Do you have the firmware for it?

Edit: also in the future, your post there is a little weak.  If you want real help, not just someone like me totally guessing, you need to provide as much information as possible.  As it is, you have the wireless card model, and "it doesn't work".  That is really not nearly enough to go on, and really indicates no effort on your part to have tried to solve this problem on your own (or with the google).

Last edited by WonderWoofy (2013-02-10 21:19:04)

Offline

#3 2013-02-10 23:19:55

ill
Member
From: US
Registered: 2011-06-22
Posts: 115

Re: [SOLVED] No Wireless Networks Shown

Sorry, not sure what else to post. I do have the linux-firmware package installed.

Offline

#4 2013-02-10 23:32:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] No Wireless Networks Shown

Logs maybe

Offline

#5 2013-02-11 00:27:14

ill
Member
From: US
Registered: 2011-06-22
Posts: 115

Re: [SOLVED] No Wireless Networks Shown

iwlwifi log from boot -- everything seems ok

Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: pci_resource_base = ffffc9000007c000
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: HW Revision ID = 0x24
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: irq 46 for MSI/MSI-X
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: loaded firmware version 18.168.6.1
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_P2P disabled
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: device EEPROM VER=0x756, CALIB=0x6
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: Device SKU: 0x1F0
Feb 10 08:01:14 gibson kernel: iwlwifi 0000:02:00.0: Valid Tx ant: 0x3, Valid Rx ant: 0x3

wicd log

Feb 10 08:18:11 gibson wicd[349]: Throttling autoreconnectSIOCSIFFLAGS: Operation not possible due to RF-kill
Feb 10 08:18:11 gibson wicd[349]: wlp2s0    Interface doesn't support scanning : Network is down

I don't know what else to post, if you can tell me specific logs to retrieve I'm happy to oblige.

Offline

#6 2013-02-11 01:11:45

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 950
Website

Re: [SOLVED] No Wireless Networks Shown

Try

rfkill unblock wifi 

Then

sudo ifconfig wlan0 up

If this doesn't work, then give us some information

output for:
lsmod
sudo rfkill list
ifconfig -a


Another suggestion would be to rmmod your wifi and modprobe it back to see if it works.

EDIT: SIOCSIFFLAGS: Operation not possible due to RF-kill  <---- this is your problem btw

Last edited by frank604 (2013-02-11 01:12:38)


github       bible       blog

Offline

#7 2013-02-11 02:29:10

ill
Member
From: US
Registered: 2011-06-22
Posts: 115

Re: [SOLVED] No Wireless Networks Shown

It worked, thanks a bunch.

Offline

#8 2013-02-11 04:50:08

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 950
Website

Re: [SOLVED] No Wireless Networks Shown

Woo hoo~! Glad it worked smile


github       bible       blog

Offline

Board footer

Powered by FluxBB