You are not logged in.

#1 2013-02-12 00:23:19

Registered: 2013-01-31
Posts: 23

Issues with SATA to USB adaptor and filesystem


I just bought an SATA to USB adapter with an external power supply. I was trying to use it with a Western Digital Caviar Green 1 TB disk, I first formatted using a regular SATA cable using an MBR partition table with a single ext4 partition covering the whole disk, starting at 1 MiB to align it properly (is that right? I was getting a warning about wrong alignment and I googled it so I created the partition using parted and left that 1 MiB free at the disk's beginning). I then proceeded to copy some data in the just created partition. I shutdown the computer, disconnected the disk, and then, after turning on the PC again, I connected the disk using the SATA-USB adapter, but the filesystem was not recognized.
I tried several times using different filesystems and using GPT instead of MBR with no results. I finally tried to create the partition table and the filesystem itself while connecting the disk with the usb adapter and it worked, now I can access the partition using the adapter. But here is the catch, if I connect the disk again using the direct SATA cable, it won't even recognize the partition table, while connecting it through the adapter will work just fine. Is this safe/reliable? I'm afraid that if there is any problem in the future I will get some headaches because if right now that the disk is working I cannot access it using a SATA cable, imagine if there's a problem!
Also, at the very same time I'm writing this post, I'm copying again the data that was intended to be in the disk through the adapter and it's copying at half the speed it did when I first did it connecting it directly with the SATA cable (30 MB/s vs 60 MB/s), is this because of the adapter? or may it because of this apparently problem with the partition table and filesystem that only works when created using the adapter?

I tried to be as clear as possible but I realize that it may sound a bit confusing, I just hope it's clear enough so you could give me some advice...


PS: What I'd like to know is if there is a way to get it to work both, when connected with the SATA cable and when connected with the adapter.
PS2: The final working configuration was using a GPT partition table and an ext4 partition using gparted while the disk was connected with the adapter.

Last edited by NaOH (2013-02-12 00:47:09)


#2 2013-02-12 11:39:56

From: Netherlands, Europe
Registered: 2005-10-04
Posts: 5,905

Re: Issues with SATA to USB adaptor and filesystem

what brand/model is the adapter ?

As for the speed difference :
Does the adapter & disk support USB3, or is it USB2 max ?

Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them


Board footer

Powered by FluxBB