You are not logged in.

#1 2013-02-12 14:13:55

omeringen
Member
Registered: 2012-05-28
Posts: 109

[SOLVED] catalyst-legacy / KWin

Hi,
I am having some issues with stable KDE 4.10 kwin and catalyst-legacy.

kwin is crashing whenever i click on "Re-enable OpenGL detection" at System Settings -> Desktop Effects. There is not much info at bug reporter because we don't have debug symbols on pacman yet. Note that the problem happens since KDE 4.10 released, it's fine on KDE 4.9.5 and older versions.

Here is my bug report at kde bugzilla : https://bugs.kde.org/show_bug.cgi?id=314194

Some information about my current system :

I have found a workaround :

omeringen wrote:

//edit : switched to the open source and again to the catalyst. It's fine and this is the second time it works. I'll possibly break like it did before if i do some changes to the desktop effects settings.

One of the KDE developer commented about it on another bug report which seemed like a duplicate but it isn't anymore : Nothing effectively changed, pot. your driver swapping wasn't complete, old libGL still loaded.


Regards. . .

Last edited by omeringen (2013-02-12 17:50:19)

Offline

#2 2013-02-12 14:52:53

siavashserver
Member
Registered: 2011-02-11
Posts: 73

Re: [SOLVED] catalyst-legacy / KWin

omeringen wrote:
  • Linux arch 3.0.62-1-lts, catalyst-lts-13.1-591, catalyst-utils-13.1-1 and ATI HD 2400

I'm not sure but if I remember correctly Vi0L0 at some point was going to drop catalyst-lts package. Remove catalyst-lts and install catalyst-hook instead, then give it a go again. May be that works.

Offline

#3 2013-02-12 14:57:01

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [SOLVED] catalyst-legacy / KWin

This time i wanted to try lts package to see if it crashes again or not. So the issue applies to non-lts catalyst and linux kernel actually.

Offline

#4 2013-02-12 15:42:49

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [SOLVED] catalyst-legacy / KWin

See what happened.
catalyst and catalyst-lts crashes like i explained but after i installed catalyst-hook i haven't experienced any crashes yet ! I wonder why. . .

Last edited by omeringen (2013-02-12 15:43:45)

Offline

#5 2013-02-12 16:39:52

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: [SOLVED] catalyst-legacy / KWin

Could be that those are not compatible with newer kernels, remember that i'm not checking how's every linux working with pre-compiled catalyst, simply cuz i don't have that much time and i'm mainly waiting for users to tell me that it's broken again cool
On the other hand : it's always better to use -hook or -generator if it's working fine. catalyst package is for those who have got problems with compilation.

There's only one very strange thing here: how could it sometimes work? LOL

Last edited by Vi0L0 (2013-02-12 17:07:45)

Offline

#6 2013-02-12 17:47:35

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [SOLVED] catalyst-legacy / KWin

@Vi0L0,
When KDE 4.10 released, with same kernel and catalyst package i have had crashes on 4.10, but no crash when i downgrade to 4.9.5
So, there is not one strange thing i guess. Mysterious. smile

Anyway, looks like it's fine with hook now. Thanks again for your interests.

Last edited by omeringen (2013-02-12 17:54:26)

Offline

#7 2013-02-12 18:10:13

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: [SOLVED] catalyst-legacy / KWin

omeringen wrote:

@Vi0L0,
When KDE 4.10 released, with same kernel and catalyst package i have had crashes on 4.10, but no crash when i downgrade to 4.9.5
So, there is not one strange thing i guess. Mysterious. smile

Actually it isn't, because KDE 4.10 switched from OpenGL 1.x to OpenGL ES 2.0, which (I don't know exactly) the legacy driver can't handle (but the free driver and the "normal" Catalyst driver can).

Offline

#8 2013-02-12 19:30:51

siavashserver
Member
Registered: 2011-02-11
Posts: 73

Re: [SOLVED] catalyst-legacy / KWin

ChemBro wrote:

Actually it isn't, because KDE 4.10 switched from OpenGL 1.x to OpenGL ES 2.0, which (I don't know exactly) the legacy driver can't handle (but the free driver and the "normal" Catalyst driver can).

Nope, OpenGL ES 2.0 is just a new (experimental) backend. KDE supports both OpenGL 1 and OpenGL 2 backends, but in case of messy drivers fallbacks to the OpenGL 1 backend. Before KDE 4.10, Catalyst drivers where blacklisted and always was using OpenGL 1 backend, but after an update to main line Catalyst drivers (8.98 branch) they are compatible with OpenGL 2 backend and are no more blacklisted in KDE 4.10. However that update never find its way into legacy Catalyst drivers (8.97 branch) and are still suffering from artifacts when forcing OpenGL 2 backend.

@omeringen : I'm glad you got it working ^^

Offline

#9 2013-02-12 20:29:10

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [SOLVED] catalyst-legacy / KWin

@ChemBro,
So, why "hook" is working but not catalyst ?

@siavashserver,
Thanks. ^^

Offline

Board footer

Powered by FluxBB