You are not logged in.

#1 2005-10-11 19:16:14

mr_brightside
Member
Registered: 2005-09-01
Posts: 78

to all those freenx users out there...

If you've got freenx to work, could you please detail the steps you took by posting in this thread? From the looks of posters in the other freenx-related threads, I and many other arch users are frustrated by our inability to use freenx in place of x11vnc...

Having done pacman -S freenx to get the latest version, I added /opt/NX/bin to $PATH and ran nxserver --adduser root followed by nxserver --passwd root and set the password for root. After this, I did nxserver --install --setup-nomachine-key. Things still didn't work after this (error given by client on XP machine is server not installed or NX access disabled). I tried carrying out the steps to alter nxserver as a text file, as described in the gentoo freenx wiki, but since the value it mentioned that should be changed (NX_AUTHORIZED_KEYS_FILE=.ssh/authorized_keys2) wasn't present in the file anyway, the alteration could not be made :?

I'd be very grateful if anyone could give some more details of how they got it to work; I'll be more than happy to add an arch wiki entry detailing the steps once I've got it to work myself.

Thanks  wink

Offline

#2 2005-10-11 21:28:50

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: to all those freenx users out there...

I had it working very well at one point. Testament by the fact that I created the package for it. wink
It was then taken over by others.

I haven't set it up in a while..but I suppose I could run through it again, and come up with a wiki for it.
/me shrugs

I got it working just fine at work the other day, connecting from a ubuntu client to a centos server.

EDIT: Did you look at the arch wiki entry for it yet? http://wiki.archlinux.org/index.php/FreeNX


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-10-11 22:45:57

mr_brightside
Member
Registered: 2005-09-01
Posts: 78

Re: to all those freenx users out there...

I don't believe it... you're a legend for posting that link; I swear I did a search in the arch wiki for 'freenx' and nothing came up.

I'll follow the guide and report if things work out or go amock. Cheers cactus  smile

Offline

#4 2005-10-12 13:41:50

mr_brightside
Member
Registered: 2005-09-01
Posts: 78

Re: to all those freenx users out there...

OK, I followed the arch linux freenx wiki, and now all the verification works perfectly; I get the Authentication completed message when I try and log into my freenx server. However, getting the display to appear is a seemingly impossible task. I'm running openbox, and have played around with the settings in the nomachine freenx client, but to no avail. Once the Authentication completed stage is reached, nothing more happens. Any ideas?

Here's the log from the freenx client on the xp machine I'm using:

NX> 203 NXSSH running with pid: 2848
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: //removed// on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: root
NX> 102 Password: 
NX> 103 Welcome to: teardrop user: root
NX> 105 listsession --user="root" --status="suspended,running" --geometry="1024x768x32+render" --type="unix-default"
NX> 127 Sessions list of user 'root' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: root
NX> 105 startsession --session="dave" --type="unix-default" --cache="8M" --images="32M" --cookie="******" --link="modem" --virtualdesktop="0" --taint="1" --render="1" --kbload="pc102/gb" --keymap="gb" --kbtype="pc102/gb" --keybd="1" --nodelay="1" --imagecompressionlevel="-1" --backingstore="never" --imagecompressionmethod="2" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="800x600x32+render" 

/etc/ssh/ssh_config: line 5: Bad configuration option: defaults
/etc/ssh/ssh_config: terminating, 1 bad configuration options

edit: I've resolved the 'Bad configuration option' at the bottom of the above log by editing my ssh_config, but this hasn't helped get the X display visible on the client. I now get the following log

NX> 203 NXSSH running with pid: 516
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 200 Connected to address: //removed// on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.4.0-44 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.5.0
NX> 134 Accepted protocol: 1.5.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: root
NX> 102 Password: 
NX> 103 Welcome to: teardrop user: root
NX> 105 listsession --user="root" --status="suspended,running" --geometry="1024x768x32+render" --type="unix-default"
NX> 127 Sessions list of user 'root' for reconnect:

Display Type             Session ID                       Options  Depth Screen         Status      Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: root
NX> 105 startsession --session="dave" --type="unix-default" --cache="8M" --images="32M" --cookie="******" --link="modem" --virtualdesktop="0" --taint="1" --render="1" --kbload="pc102/gb" --keymap="gb" --kbtype="pc102/gb" --keybd="1" --nodelay="1" --imagecompressionlevel="-1" --backingstore="never" --imagecompressionmethod="2" --media="0" --agent_server="" --agent_user="" agent_password="******""  --screeninfo="800x600x32+render" 

NX> 1000 NXNODE - Version 1.4.0-44 OS (GPL)
NX> 700 Session id: teardrop-1012-635D7C9701F3ABFE362FCCE61F3B7ECB
NX> 705 Session display: 1012
NX> 703 Session type: unix-default
NX> 701 Proxy cookie: 74d2c86db3ae5026aced48e8ee8054c5
NX> 702 Proxy IP: //removed//
NX> 706 Agent cookie: 74d2c86db3ae5026aced48e8ee8054c5
NX> 704 Session cache: unix-default
NX> 707 SSL tunneling: 0
NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye

Offline

#5 2005-10-12 15:55:19

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: to all those freenx users out there...

What session are you having freenx start. I remember there are options for 'default' 'gnome' 'kde'...some stuff like that. Likely the option you are choosing is not translating well to a start command. I remember there was some hoop I had to go through to get openbox to start at one point..and it came down to me changing some Xinit config files on the server side, and selecting something like 'kde' on the client side (i had mapped kde start info to openbox or something)...

but I dont remember for sure. sorry. sad


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#6 2005-10-12 19:40:52

mr_brightside
Member
Registered: 2005-09-01
Posts: 78

Re: to all those freenx users out there...

I'm trying to start an openbox session; I'll try symlinking openbox to startkde, and put startkde in .xinitrc... I'll post when I know what happens.

Offline

Board footer

Powered by FluxBB