You are not logged in.

#1 2013-02-14 20:17:23

Hindol
Member
Registered: 2008-05-07
Posts: 15

[SOLVED] Font problem. Zsh prompt shows strange characters.

I am seeing strange characters in Zsh prompt only, bash works fine. I probably did not follow the font configuration section of Arch Beginner's Guide properly during installation. Earlier I had problems with login consoles too (tty2, tty3, all those black screens you can go to using CTRL+ALT+F2/F3 etc.) But I fixed those problems by creating /etc/vconsole.conf.

Zsh problem still remains. I am using oh-my-zsh.

I am out of ideas as to what to do. Please help.

Garbled prompt on Zsh

Last edited by Hindol (2013-04-23 08:37:47)

Offline

#2 2013-02-14 20:21:46

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,075
Website

Re: [SOLVED] Font problem. Zsh prompt shows strange characters.

What happens if you remove all the oh-my-zsh stuff?

From your screenshot it looks like you are in X: you might want to change your thread title as it is a little misleading.

Check your locale while you are at it.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-04-23 08:39:48

Hindol
Member
Registered: 2008-05-07
Posts: 15

Re: [SOLVED] Font problem. Zsh prompt shows strange characters.

This thread was kind of old. Sorry for bumping this up.

Finally I solved my problem by setting proper locales in .zshrc. Apparently gnome-terminal shows UTF-8 chars only when LANG is set to some UTF-8 charset.

Offline

Board footer

Powered by FluxBB