You are not logged in.

#1 2013-02-14 23:35:09

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Sound plays back too fast in Half-Life (Steam)

Audio files in half-life play back at far too fast of a speed, resulting in a hilariously high pitch. I originally was just running ALSA and then begrudgingly installed PulseAudio. Same issue there.

Does anybody have any ideas? Is this a known bug with the GoldSrc engine? I did find this: http://steamcommunity.com/app/70/discus … 379785189/, but no other mention.

Offline

#2 2013-02-15 15:10:46

Arctus
Member
Registered: 2012-07-14
Posts: 85

Re: Sound plays back too fast in Half-Life (Steam)

Just tried it, didn't hear anything wrong, but only listened to the intro part on the train.

Offline

#3 2013-02-15 17:03:46

jakobcreutzfeldt
Member
Registered: 2011-05-12
Posts: 1,031

Re: Sound plays back too fast in Half-Life (Steam)

Sounds like a sample rate problem. Are you doing anything weird with setting your sound cards sample rate?

Offline

#4 2013-02-17 08:25:40

johni
Member
Registered: 2012-02-03
Posts: 102

Re: Sound plays back too fast in Half-Life (Steam)

I just purchased Half-Life on steam, and I am having the same problem.  Though, it is more than just the audio fast - the whole train intro is running too fast.  Notice the guys driving the fork lift at the beginning are zipping by fast, too.

Have you found any solution?

Offline

#5 2013-02-17 20:09:59

johni
Member
Registered: 2012-02-03
Posts: 102

Re: Sound plays back too fast in Half-Life (Steam)

I found a workaround.    Start the game outside of steam, and all is well.   You do have to have steam running, but start the game from the command line like this:

cd ~/.steam/root/SteamApps/common/Half-Life
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. ./hl_linux -game valve

Also, to use alsa insteam of pulse, before the above, do:

export SDL_AUDIODRIVER=alsa

Offline

#6 2013-02-18 14:36:52

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Sound plays back too fast in Half-Life (Steam)

Odd... Thanks for the help! I hope this gets resolved.

And,

jakobcreutzfeldt wrote:

Sounds like a sample rate problem. Are you doing anything weird with setting your sound cards sample rate?

No, I'm not.

Offline

Board footer

Powered by FluxBB