You are not logged in.

#1 2013-02-14 23:52:37

Dtag
Member
Registered: 2012-11-20
Posts: 3

cpupower frequency too low

Hi,

I have a laptop with an Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz, running on kernel "3.7.7-1-ARCH". When my AC is plugged in, it stays at 2.2 Ghz which is fine. When I unplug AC, it goes down to a max of 1.5Ghz.
I assumed that the frequency scaling governor has to do with that. Thus I set the governor to "performance" instead of the standard "ondemand" using
# cpupower frequency-set -g performance
calling
# cpupower frequency-info
Confirms that the governor has changed:

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3 4 5 6 7
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.20 GHz
  available frequency steps: 2.20 GHz, 2.20 GHz, 2.00 GHz, 1.90 GHz, 1.80 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 1000 MHz, 900 MHz, 800 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 800 MHz and 1.50 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.50 GHz.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores


The problem is that it still says that the "frequency should be within 800 MHz and 1.50 GHz". Obviously, the maximum freq. is too low. Also I called for the performance governor, which should fix the freq at max. Why is this not happening? How can I influence the maximum frequency? Who is in charge of the changes that occur when AC is plugged/unplugged and how can that be influenced?

Thanks!

Offline

#2 2013-02-15 00:33:38

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: cpupower frequency too low

Have you checked to see if there is any throttling being done in the BIOS?


I laugh, yet the joke is on me

Offline

#3 2013-02-15 07:12:46

Dtag
Member
Registered: 2012-11-20
Posts: 3

Re: cpupower frequency too low

Hi,

there were indeed two AC/Battery specific settings in the BIOS, that were set incorrectly. The AC one was at "Maximum performance" both times, whereas the Battery setting was "Balanced". Not sure how I could forget to check the BIOS.

Unfortunately though, the problem remains even after making these changes!

Thanks

Offline

#4 2013-02-15 23:40:21

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: cpupower frequency too low

Not sure what to tell you then, since it may be that the BIOS has some Windows specific way of communicating the change that isn't crossing over to your Arch install.  I still suspect your BIOS however.  Have you checked if there is a firmware update for it?  That is where I would start looking next.


I laugh, yet the joke is on me

Offline

#5 2013-02-16 00:19:49

ilkyest
Member
From: Brazil
Registered: 2010-02-13
Posts: 267

Re: cpupower frequency too low

Does intel speed step active on BIOS?

Does intel speed step installed on arch? I don't know if hasn't to install it

Offline

Board footer

Powered by FluxBB