You are not logged in.

#1 2013-02-15 12:36:22

kolombo
Member
From: Ukraine
Registered: 2011-12-14
Posts: 31

[SOLVED] ATI driver stopped to work.

After last upgrade I can't enable ATI driver. Before I needed to disable KMS due to system freeze issues.
I used xf86-video-ati-6.14.6-2 package all the time, because new one caused problems.

After last upgrade Xorg stopped to boot with xf86-video-ati-6.14 and I had to upgrade it. But  xf86-video-ati-1:7.1.0-1
doesn't work with disabled KMS and now I stuck with VESA driver.

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV516 [Mobility Radeon X1350]

Xorg.log:

[    15.307] (II) [KMS] drm report modesetting isn't supported.
[    15.307] (II) [KMS] drm report modesetting isn't supported.
[    15.307] (II) [KMS] drm report modesetting isn't supported.
[    15.307] (WW) Falling back to old probe method for modesetting
[    15.309] (WW) Falling back to old probe method for fbdev
[    15.309] (II) Loading sub module "fbdevhw"
[    15.309] (II) LoadModule: "fbdevhw"
[    15.310] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    15.318] (II) Module fbdevhw: vendor="X.Org Foundation"
[    15.318]    compiled for 1.13.2, module version = 0.0.2
[    15.318]    ABI class: X.Org Video Driver, version 13.1
[    15.318] (EE) open /dev/fb0: No such file or directory
[    15.319] (EE) Screen 0 deleted because of no matching config section.
[    15.319] (II) UnloadModule: "radeon"

Does anybody has any idea how to resolve this ?

Last edited by kolombo (2013-02-15 17:13:00)

Offline

#2 2013-02-15 17:11:35

kolombo
Member
From: Ukraine
Registered: 2011-12-14
Posts: 31

Re: [SOLVED] ATI driver stopped to work.

OK, I have found workaround.

Disable KMS in /etc/modprobe.d/radeon.conf, otherwise system will not boot sad

options radeon modeset=0

Create /etc/rc.local

#!/bin/sh
modprobe -r -v radeon drm
modprobe -v drm debug=1
modprobe -v radeon modeset=1

Create systemd init script /usr/lib/systemd/system/rc-local.service:

Description=/etc/rc.local Compatibility
ConditionPathExists=/etc/rc.local

[Service]
Type=forking
ExecStart=/etc/rc.local start
TimeoutSec=0
StandardOutput=tty
RemainAfterExit=yes
SysVStartPriority=99

[Install]
WantedBy=multi-user.target

Enable rc-local.service

Now Radeon driver works with KMS, will see if I have system freeze smile

Offline

#3 2013-04-12 14:07:00

chippy99
Member
From: London
Registered: 2012-07-14
Posts: 1

Re: [SOLVED] ATI driver stopped to work.

Thanks this worked for me. Spent ages looking for an answer to this.
Just one thing, don't forget to chmod +x the rc.local or it won't work.

Offline

#4 2013-07-24 15:02:01

mage
Member
Registered: 2012-03-23
Posts: 2

Re: [SOLVED] ATI driver stopped to work.

I have same problem with my thinkpad x120e. Will try your workaround.

Last edited by mage (2013-07-24 15:10:09)

Offline

#5 2013-07-24 15:54:43

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,176

Re: [SOLVED] ATI driver stopped to work.

Hello mage,  Welcome to Arch Linux.

This thread has been marked at solved, so you may not get much in the way of response by posting here.  Also, the thread is getting a little old.

I am going to go ahead and close this thread.   If the work around does not work for you, or if you have additional questions, feel free to start a new thread and refer back to this one.

Thanks.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB