You are not logged in.

#1 2013-02-16 00:18:08

ilkyest
Member
From: Brazil
Registered: 2010-02-13
Posts: 261

some issues about ethernet and arch linux.

Hello pals. A very strange thing is annoying me a while. I'm folding at home user, and when I let my computer folding more than a day my internet navigations get a little "censored" thing.

before, with rc.d I did a "rc.d restart ethernet" and most of time was solved. With systemd and/or network manager I couldn't found this command

What happens is like if mtu get in 200. Navigations turns so slow, even pacman. At this time, I should reboot linux to make it normal.

I tried change ethernet card but, with 3c905BX I should change MTU to 1500 to navigate at all

hwinfo --netcard
39: PCI 506.0: 0200 Ethernet controller                         
  [Created at pci.319]
  Unique ID: JNkJ.Er3ucFQoZE2
  Parent ID: qscc.UsCA9N2eQqB
  SysFS ID: /devices/pci0000:00/0000:00:14.4/0000:05:06.0
  SysFS BusID: 0000:05:06.0
  Hardware Class: network
  Model: "3Com 3C905B Fast Etherlink XL 10/100"
  Vendor: pci 0x10b7 "3Com Corporation"
  Device: pci 0x9055 "3c905B 100BaseTX [Cyclone]"
  SubVendor: pci 0x10b7 "3Com Corporation"
  SubDevice: pci 0x9055 "3C905B Fast Etherlink XL 10/100"
  Revision: 0x30
  Driver: "3c59x"
  Driver Modules: "3c59x"
  Device File: eth1
  I/O Ports: 0xdc00-0xdc7f (rw)
  Memory Range: 0xfebfbc00-0xfebfbc7f (rw,non-prefetchable)
  Memory Range: 0xfebc0000-0xfebdffff (ro,non-prefetchable,disabled)
  IRQ: 21 (13361 events)
  HW Address: 00:50:04:ab:2f:30
  Link detected: yes
  Module Alias: "pci:v000010B7d00009055sv000010B7sd00009055bc02sc00i00"
  Driver Info #0:
    Driver Status: 3c59x is active
    Driver Activation Cmd: "modprobe 3c59x"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #20 (PCI bridge)

40: PCI 700.0: 0200 Ethernet controller
  [Created at pci.319]
  Unique ID: rBUF.2dzJn7ktuZF
  Parent ID: I+Ba.k8kP4VdaZm3
  SysFS ID: /devices/pci0000:00/0000:00:15.1/0000:07:00.0
  SysFS BusID: 0000:07:00.0
  Hardware Class: network
  Model: "Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168B PCI Express Gigabit Ethernet controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8432
  Revision: 0x06
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  I/O Ports: 0xe800-0xe8ff (rw)
  Memory Range: 0xfdfff000-0xfdffffff (ro,non-prefetchable)
  Memory Range: 0xfdff8000-0xfdffbfff (ro,non-prefetchable)
  IRQ: 51 (354936 events)
  HW Address: 20:cf:30:e4:2a:f1
  Link detected: no
  Module Alias: "pci:v000010ECd00008168sv00001043sd00008432bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)

So
1) can I restart ethernet with systemd? how?
2) how could I set arch to use eth1, just it? blacklist r8169 module?
3) how could I set eth1 to, every time, uses 1500 of mtu?

Offline

Board footer

Powered by FluxBB