You are not logged in.

#1 2013-02-20 09:09:39

aphirst
Member
From: Munich, Germany
Registered: 2008-06-30
Posts: 56
Website

[SOLVED] Cannot start X - Catalyst 13.1, HD7340, HP DM1-4341SA

UPDATE: I discovered that this problem only occurs when "Legacy Support" in the BIOS menu is disabled. I had disabled it after the install finished since I thought I wouldn't need that enabled anymore, but on re-enabling it X seems to work perfectly with catalyst. Is this a known problem, or is this worth notifying anyone over? And if so, where?

I'm trying to get Arch set up on my new-ish netbook to use the proprietary ATI driver. I can get the open-source driver working, but that's not really what I'm after. I followed the beginner's guide to the letter, with the following exceptions:

>The netbook's motherboard is UEFI, so I made the EFI partition to use rEFInd
>I'm using an SSD, so I set the discard flag in fstab (using ext4 for / )
>I added nomodeset to /boot/efi/EFI/arch/refind.conf
>I installed linux-headers, then catalyst-dkms and catalyst-utils, along with xorg-server and mesa and xorg-twm etc.
>I ran aticonfig --initial as root, and to be safe I put blacklist radeon in modprobe.conf
>Reboot

startx gives the following error:

ion support No m at http://wiki.x.org for help. (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.(EE) Server terminated with error (1). Closing log file.
 xinit: giving up
xinit: unable to connect to X server: Connection refused.
xinit: server error

And the (EE) and (WW) entries in the logfile are:

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) Falling back to old probe method for fglrx
(WW) fglrx: no matching Device section for instance (BusID PCI:0@0:1:1) found

(EE) fglrx(0): V_BIOS address 0x0 out of range
(EE) fglrx(0): Failed to obtain VBIOS from kernel!
(EE) fglrx(0): VBIOS read from Kernel, Invalid signature!
(EE) fglrx(0): GetBIOSParameter failed
(EE) fglrx(0): PreInitAdapter failed
(EE) fglrx(0): PreInit failed
(EE) Screen(s) found, but none have a usable configuration.

My xorg.conf is currently:

Section "ServerLayout"
    Identifier    "aticonfig Layout"
    Screen    0   "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Monitor"
    Identifier    "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier    "aticonfig-Device[0]-0"
    Driver        "fglrx"
    BusID         "PCI:0:1:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth    24
    SubSection "Display"
        Viewport 0 0
        Depth   24
    EndSubSection
EndSection

But yeah, I can't get X to load. I've searched for my hardware and error messages on the forums, wiki, and using Google and can't work out what's going wrong. Obviously it's possible I missed something, but still.

If anyone has any ideas, or thinks there's any information I've omitted that would help, then I eagerly await your reply. I'll update this post with the extra stuff.

Last edited by aphirst (2013-02-20 15:55:01)


ArchLinux | x86_64 | linux-ck-sandybridge
OpenBox3 | tint2 | sakura | PCManFM | Pale Moon | FossaMail | Code::Blocks | GCC
Lenovo Thinkpad T430 | 14.1" | i7-3540M (2.5GHz) | HD 4000 | 16GB (1066MHz) | 256GB mSATA SSD | 1TB HDD | 500GB HDD

Offline

Board footer

Powered by FluxBB