You are not logged in.

#1 2013-02-26 12:33:47

Registered: 2009-06-07
Posts: 347

Passing TrusCont Content Protection

I purchased an app for Windows (nothing like this particular app exists for Linux) and it has "TrusCont Content Protection" apparently. I have a real Windows XP box (quite old) and the USB installs fine there and the app runs. On my Arch box, my Wine is broken so I can't really try there. But I tried on a real Debian box and it recognizes the USB drive and the app installs fine in Wine, but when I launch the app I get "please insert original USB". Same thing when I install it on a VirtualBox running Debian on my Arch box.

I tried to install it on Windows 7 and Windows Vista running in VirtualBox on my Arch box, but neither one can figure out the driver for this USB. My native XP box downloaded and installed the drivers fine but the two Vboxes can't find a driver. The device shows up as "TrusCont Publisher USB" in Vbox so it appears it's this: and on that page they say they don't support Linux. sad

I first had a DVD version of this app and tried using dd to make an ISO and while my Vboxes see the ISO and I can install the app, I still can't launch--it says "please insert original CD". The only thing I didn't try was using the original DVD and exposing that to a Windows Vbox. The reason was because my DVD player on my Arch box is broken. I didn't think of switching it until after I exchanged the DVD for the USB.

Anyhow, does anyone have any ideas how I can get this thing to run in Wine or Vbox?


Board footer

Powered by FluxBB