You are not logged in.

#1 2013-02-26 22:04:53

kYd
Member
Registered: 2009-01-20
Posts: 78

FN keys always enabled on Lenovo laptop

I've got a new laptop, all works great apart from one annoying 'feature' that Lenovo added: the FN keys are always enabled, so pressing, say F4 acts as if pressing ALT-F4. thus closing the running program, which is quite annoying as it is next to the F3 key which controls the volume and I have quite often accidentally closed an program.
If I want to use the actual FN function (say F2 to exit nano) I have to press FN+F2.

The same issue happends within the pre-installed version of Windows 8. so I know it's not a linux problem.
I've looked in the BIOS and can't seem to find any thing related to the keyboard, function or multimedia keys, so can any one think a way around this issue?

Thanks.

Offline

#2 2013-02-27 13:11:19

Raynman
Member
Registered: 2011-10-22
Posts: 1,074

Re: FN keys always enabled on Lenovo laptop

My Lenovo laptop (Thinkpad x121e) has a setting 'Fn Key Lock' on the Config tab in the BIOS and I thinks it's quite a common option (for Thinkpads at least), together with 'swap fn and ctrl'.

If yours doesn't have this option, I guess your only hope is some creative remapping (which probably means you have to do some reading tongue).

Last edited by Raynman (2013-02-27 13:13:30)

Offline

Board footer

Powered by FluxBB