You are not logged in.

#1 2013-02-26 22:14:45

stp002
Member
Registered: 2011-12-26
Posts: 28

automounting /root and /boot on media!

Hi everyone,
I recently updated my arclinux.After that my /root and /boot are auto mounted on /media.How do i disable that.I have little experience with udev rules so I don't want to fiddle with it.Just a small question about core dumps.Is it enabled by default.
Any help in this redard will be appreciated.
Thanks

Offline

#2 2013-02-26 22:46:44

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: automounting /root and /boot on media!

Post fstab.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2013-02-26 22:53:17

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,073
Website

Re: automounting /root and /boot on media!

Also, remove your udev automounting rule (or adapt it so it doesn't include those partitions)...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2013-02-27 12:23:38

stp002
Member
Registered: 2011-12-26
Posts: 28

Re: automounting /root and /boot on media!

Thank you all  for your help and tips.Please see the fstab file.

  # 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
tmpfs		/tmp	tmpfs	nodev,nosuid	0	0
/dev/sda3 /boot ext3 defaults 0 1
/dev/sda6 / ext4 defaults 0 1
/dev/sda5 swap swap defaults 0 0
debugfs /sys/kernel/debug   debugfs      defaults 0 0  

Thanks.

Offline

#5 2013-02-27 12:51:59

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,377

Re: automounting /root and /boot on media!

You can remove the tmpfs and debugfs entries, as systemd mounts these by default. Furthermore, only / should have a pass_no of 1, if you want /boot to be fscked, change it's "1" to a "2".

Other than that, your fstab looks fine to me.

Are you using any automount helpers (e.g. devmon, udiskie, or similar)?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#6 2013-02-27 23:06:40

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: automounting /root and /boot on media!

I have the mountpoint for swap as "none" rather than "swap" but perhaps those are equivalent?

Probably just a question of removing or editing the udev rule then.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB