You are not logged in.

#1 2013-02-28 07:23:20

ironeagle
Member
Registered: 2013-02-28
Posts: 2

[solved] VMware can not find correct kernel header

Hi,

I've a Problem with VMware Player since one or two month now. When I try to start the player I got the message:

Before you can run VMware, several modules must be compiled and loaded into the running kernel.

Kernel headers for version 3.7.9.2-ARCH were not found. If you installed them in a non default path .....

Then he ask me to choose the directory with teh kernel header. I did so, but vmware was not satisfied. Instead I got the following error message:

C header files matching your running kernel were not found.  Refer to your distribution's documentation for installation instructions.

I already tried to search for that problem, but there seems to be several different reasons. According to https://wiki.archlinux.org/index.php/VM … m.5B....5D I tried to reinstall the kernel header and reboot. But that had no effect. Choosing one of the subdirectories of the kernel header instead of the main directory didn't work either. Is there anything else, I can try?

My kernel is: 3.7.9-2-ARCH #1 SMP PREEMPT
The kernel headers are under /usr/src/linux-3.7.9-2-ARCH/
vmware player is: VMware Player 5.0.1 build-894247 (installed from arch repository)

Thank you!

Last edited by ironeagle (2013-02-28 10:54:47)

Offline

#2 2013-02-28 10:53:41

ironeagle
Member
Registered: 2013-02-28
Posts: 2

Re: [solved] VMware can not find correct kernel header

Fixed! Since the file version.h moved but vmware expect the file at the old location, a symlink must be created:

# ln -s /usr/src/linux-3.7.9-2-ARCH/include/generated/uapi/linux/version.h /usr/src/linux-3.7.9-2-ARCH/include/linux/version.h

After that, another error occured, that says, that some executable file could not be found. Here, the solution is also the creation of symlinks (according to another thread in this forum)

# ln -s /usr/bin/kmod /sbin/modinfo
# ln -s /usr/bin/kmod /sbin/lsmod
# ln -s /usr/bin/kmod /sbin/insmod
# ln -s /usr/bin/kmod /sbin/rmmod

Last edited by ironeagle (2013-02-28 10:56:37)

Offline

#3 2013-03-06 05:09:18

radiomist
Member
From: superposicion
Registered: 2009-11-27
Posts: 62

Re: [solved] VMware can not find correct kernel header

Hey, thanks smile
I had same problem with linux-3.8.2-1

Offline

Board footer

Powered by FluxBB