You are not logged in.

#1 2013-03-01 11:25:53

Registered: 2010-10-23
Posts: 99

[SOLVED] .load partitions from '/dev/sdb'! Aborting! - cgdisk /dev/sdb

I am having a problem with partitioning. I try to install arch from UEFI bootable USB disk. I can boot and login as root. I have two hard disks attached

/dev/sda - 3.7gb USB disk from which the installation medium was booted
/dev/sdb - 160gb ssd hard disk on which arch needs to be installed

when I do cgdisk /dev/sdb, it says could not load partitions from '/devsdb' Aborting!

When I try cfdisk /dev/sdb, I can create the partitions, but the newbie instructions say

Notes regarding UEFI boot:

    If you have a UEFI motherboard, you will need to create an extra UEFI System partition.
    It is recommended to always use GPT for UEFI boot, as some UEFI firmwares do not allow UEFI-MBR boot.

Therefore, I only want to stick with cgdisk partitioning. How can I do it? I have searched a lot, not a single result was found on this error except the cgdisk source code comment

if (theGPT.LoadPartitions(device)) {
      if (theGPT.GetState() != use_gpt) {
         Report("Warning! Non-GPT or damaged disk detected! This program will attempt to\n"
                "convert to GPT form or repair damage to GPT data structures, but may not\n"
                "succeed. Use gdisk or another disk repair tool if you have a damaged GPT\n"
      } // if
   } else {
      Report("Could not load partitions from '" + device + "'! Aborting!");
   } // if/else

The condition theGPT.LoadPartitions(device) apparently returns false.

Last edited by Archie_Enthusiasm (2013-03-01 15:39:50)


#2 2013-03-01 11:48:38

Inspector Parrot
Registered: 2011-11-29
Posts: 20,283

Re: [SOLVED] .load partitions from '/dev/sdb'! Aborting! - cgdisk /dev/sdb

man cfdisk wrote:

Next, cfdisk tries to read the current partition table from the disk drive. If it is unable to figure out the partition table, an error is displayed and the program will exit. This might also be caused by incorrect geometry information, and can be overridden on the command line. Another way around this problem is with the -z option. This will ignore the partition table on the disk.

"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman


#3 2013-03-01 14:23:29

Registered: 2013-02-22
Posts: 262

Re: [SOLVED] .load partitions from '/dev/sdb'! Aborting! - cgdisk /dev/sdb

sgdisk  --clear /dev/sdb

Clear out all partition data. This includes GPT header data, all partition definitions, and the protective MBR. Note that this operation will, like most other operations, fail on a damaged disk. If you want to prepare a disk you know to be damaged for GPT use, you should first wipe it with -Z and then partition it normally. This option will work even if the disk's original partition table is bad; however, most other options on the same command line will be ignored.

Then partition the drive:

cgdisk  /dev/sdb


Board footer

Powered by FluxBB